SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] sottotitoli vlc/smplayer
#11
Come temevo non c'entra convertirlo come(mi ero dimenticato) non c'entra niente avere il doppio punto nel nome del sottotitolo.
Cita messaggio
Grazie da:
#12
Il file srt che stai utilizzando contine delle istruzioni di formattazione che non sono completamente standard. Alcuni visualizzatori riescono ad interpretarli, altri no. Apri un terminale e dai il comando
Codice:
mplayer <nome del file video>
dove <none del file video> è appunto il nome del file video (eventualmente vai nella cartella che contiene il video che vuoi visualizzare).
Ti appariranno al terminale una serie di informazioni, tra cui se il file dei sottotitoli è stato caricato correttamente. Una cosa del tipo:
Codice:
mplayer Storks.2016.1080p.BluRay.x264-\[YTS.AG\].mp4
MPlayer 1.2-4.9.2 (C) 2000-2015 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Storks.2016.1080p.BluRay.x264-[YTS.AG].mp4.
libavformat version 56.40.101 (external)
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f10679d5b80]Protocol name not provided, cannot determine if input is local or a network protocol, buffers and access patterns cannot be configured optimally without knowing the protocol
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO:  [H264]  1920x800  24bpp  23.976 fps  2050.6 kbps (250.3 kbyte/s)
Clip info:
major_brand: isom
minor_version: 512
compatible_brands: isomiso2avc1mp41
encoder: Lavf57.22.100
Load subtitles in ./
SUB: Added subtitle file (1): ./Storks.2016.1080p.BluRay.x264-[YTS.AG].srt
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 56.60.100 (external)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, floatle, 123.5 kbit/4.02% (ratio: 15442->384000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample)
Starting playback...

Come vedi, nel mio caso il file dei sottotitoli è stato caricato correttamente.  Io comunque mi sono fatto un programmino che "pulisce" il file srt da queste istruzioni estese (di solito agiscono sul tipo di font, colore e stile (neretto, italico)).  Dato che sono dei normali file di testo, puoi usare un editor e toglierli a mano, tanto non sono moltissimi, se ci sono.

Non c'entra nulla il doppio punto ed il formato video. Quello che conta è che il file video ed il file srt abbiano ESATTAMENTE lo stesso nome, a parte l'estensione.

Ciao, Mauro
CPU: Intel 6-Core i7-5820K (Haswell rev.2)
nVidia GeForce GTX 750 (drv 430.26), 16GB DDR4 RAM
‎Intel C610/X99 HD Audio / Intel I210 Gigabit Network
Supermicro C7X99-OCE
KDE Plasma:5.16.1 Frameworks:5.59.0 Apps:19.04.2
X.org:1.20.5 Qt:4.8.7/5.12.3
Kernel 5.1.11-pclos1 (gcc-8.3.1-0.6pclos2019)
Cita messaggio
Grazie da:
#13
Una ulteriore informazione, riguardante nello specifico vlc. Prova a controllare le codifiche utilizzate per i sottotitoli. Le trovi in

Strumenti->Preferenze->Ingresso/Codificatori->(in basso seleziona 'tutto' in 'Mostra le Impostazioni)->Apri il menu a sinistra 'Codificatori dei sottotitoli'->Sottotitoli

Prova a cambiare le impostazioni e vedere se funziona:

[Immagine: http://i66.tinypic.com/28k4wnc.jpg]

Ciao, Mauro
CPU: Intel 6-Core i7-5820K (Haswell rev.2)
nVidia GeForce GTX 750 (drv 430.26), 16GB DDR4 RAM
‎Intel C610/X99 HD Audio / Intel I210 Gigabit Network
Supermicro C7X99-OCE
KDE Plasma:5.16.1 Frameworks:5.59.0 Apps:19.04.2
X.org:1.20.5 Qt:4.8.7/5.12.3
Kernel 5.1.11-pclos1 (gcc-8.3.1-0.6pclos2019)
Cita messaggio
Grazie da:
#14
Grazie footostep11 per la risposta,allora come detto in win10 con vlc si vede correttamente e sol con pclos sia mate che kde plasma ho questo problema.
I settaggi dei sottotitoli li avevo già provati ma non cambia nulla.ora ti allego il file txt che ho salvato dopo il comando "mplayer" a terminale,ho dovuto modificare il titolo dell'mp4 e aggiungere il punto dopo ogni parola altrimenti la risposta era che non trovava il file.
Ciao e grazie,cosa significa il file che ho salvato lo lascio a te in quanto non ci capisco quasi niente.

P.S.
Se si può al limite usare il tuo programmino non sarebbe male,certo lo sò è un lavoro tuo... Smile


Allegati
.txt   mplayer.txt (Dimensione: 3,43 KB / Download: 2)
Cita messaggio
Grazie da:
#15
Dal tuo file risulta che il file di sottotitoli e' stato caricato correttamente
Codice:
Load subtitles in ./
SUB: Added subtitle file (1): ./Oil.Painting.Tropical.Paradise.srt
Il problema sembra quindi essere che vlc non riconosce i comandi di formattazione del testo. Li puoi eliminare usando il programma che ti allego (e' un programmino in perl. Se vuoi vedere cosa fa aprilo con un editor di testo). Lo lanci da terminale dandogli come argomento il file srt (senza argomento ti chiedera' il file srt da convertire, mentre se lo lanci con il flag -a convertira' tutti i files srt che trova nella cartella dove si trova - in altre parole 'clean-srt -a').

Ciao, Mauro

PS Per poter allegare il programma ho dovuto chiamarlo clean-srt.txt. Bisogna rinominarlo clean-srt (senza estensione).
Nel caso non sapessi come rendere eseguibile il programma e visibile da ogni cartella, le istruzioni sono (se hai salvato clean-srt nella tua HOME):
Codice:
chmod 755 clean-srt.txt
mkdir bin
mv clean-srt bin/clean-srt


Allegati
.txt   clean-srt.txt (Dimensione: 1,55 KB / Download: 1)
CPU: Intel 6-Core i7-5820K (Haswell rev.2)
nVidia GeForce GTX 750 (drv 430.26), 16GB DDR4 RAM
‎Intel C610/X99 HD Audio / Intel I210 Gigabit Network
Supermicro C7X99-OCE
KDE Plasma:5.16.1 Frameworks:5.59.0 Apps:19.04.2
X.org:1.20.5 Qt:4.8.7/5.12.3
Kernel 5.1.11-pclos1 (gcc-8.3.1-0.6pclos2019)
Cita messaggio
Grazie da:
#16
Ciao e grazie,ora sono curioso di vedere come hai scritto il programmino Smile
Comunque ho fatto in fretta anche con libre office con il "cerca e sostituisci",il punto è che non è logico un tale funzionamento! se sullo stesso pc con win10 e vlc lo vedo correttamente mi aspetto che vlc in linux faccia altrettanto,non credo sia un problema di vlc in sè sono più convinto sia più un problema di qualche settaggio del S.O. il guaio è dove! Aspetto a mettere risolto anche perchè obbiettivammente risolto non è.

Ciao e ancora grazie e buona giornata
Cita messaggio
Grazie da:
#17
Per correttezza devo fare una rettifica,ho avviato windows10 e riprovato a vedere il filmato ,non solo quello in questione ma anche altri video con sottotitoli con la stessa formattazione,ora li vedo alla stessa maniera di come li vedo in linux...eppure ieri li vedevo correttamente Disperato Disperato non ho parole,dirò di più inizio a non capirci più niente!
Metto risolto in quanto o con libreoffice o con il programmino di footstep11 si risolve parzialmente il problema,q sto punto mi domando a cosa serve una formattazione del testo se poi non viene letta dai player Undecided mah!
Buona giornata a tutti
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)