Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] swap non riconosciuta
#1
salve, ho fatto un'installazione di Korora (derivata di Fedora) in coppia con Linux Mint 17.3 Rosa, entrambe a 32 bit, solo che la swap che ho creato per Mint non c'è (ho aperto il task manager per vedere i consumi). la cosa è strana perché di solito io non creo mai due swap per un dualboot, per esempio ho PClinuxOS con Manjaro e la swap è riconosciuta per tutti e due i sistemi. c'è possibilità di attivare quella swap creata per Mint? o devo reinstallare? grazie.
Cita messaggio
Grazie da:
#2
non si capisce, hai un pc con 4 sistemi? o oppure i pc sono 2 e il problema ce l'hai solo su quello con korora/mint?

avvia mint e posta l'output di questo

Codice:
sudo blkid && cat /etc/fstab
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#3
ho due hard disk con quattro sistemi, uno pclinuxos/manjaro (dove la swap è unica ed è riconosciuta su tutti e due) e uno korora/mint (swap unica riconosciuta solo da mint). appena posso posto il risultato da terminale.
Cita messaggio
Grazie da: Ovotux
#4
mah, la swap secondo me va bene solo una, basta quella che hai su uno dei due dischi

EDIT commenta quella nel fstab di korora e mint e inserisci la riga riferita alla swap di manjaro/pclinuxos
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#5
il riultato del codice di prima da mint come avevi detto:

/dev/sda1: UUID="85feba6f-4e1b-45e3-949b-c7bebe9ffd0a" TYPE="ext4"
/dev/sda5: UUID="5c65704a-abb4-4f96-a54e-13bc73b35742" TYPE="swap"
/dev/sda6: UUID="962781d3-14b2-4197-866e-a46ebd943164" TYPE="ext4"
/dev/sdb1: LABEL="SB@" UUID="40f04001-5a61-452d-a9ee-60043d4b1c2c" TYPE="ext4"
/dev/sdb2: LABEL="SB@SWAP" UUID="9d6a3d89-a731-485c-bc64-b637f1244a89" TYPE="swap"
/dev/sdb3: UUID="PLknsM-c6r7-BGO2-1usZ-h820-1aO8-qXMSkt" TYPE="LVM2_member"
/dev/mapper/korora-root: UUID="3fb7788f-9785-4bbc-8180-70c2c104bfd7" TYPE="ext4"
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# /
UUID=40f04001-5a61-452d-a9ee-60043d4b1c2c   /   ext4   noatime,errors=remount-ro   0   1
# SWAP
UUID=9d6a3d89-a731-485c-bc64-b637f1244a89   none   swap   sw   0   0

ps: non sapevo che una swap potesse andare bene per due dischi, non si fiinice mai di imparare...

(15-02-2016,18:51 )tuxino Ha scritto: mah, la swap secondo me va bene solo una, basta quella che hai su uno dei due dischi

EDIT commenta quella nel fstab di korora e mint e inserisci la riga riferita alla swap di manjaro/pclinuxos

non so come fare, se mi postassi la soluzione ti sarei grato. e poi la wap creata per korora/mint? la devo cancellare?

EDIT: forse è meglio tenere le due swap per non complicarmi le cose. se puoi postami olo come attivare la swap su Korora, grazie per la pazienza.
Cita messaggio
Grazie da:
#6
mah cè un casino....e non so se avere 2 swap crea problemi, ora che sei su mint prova a cambiare questa in fstab
# SWAP
UUID=9d6a3d89-a731-485c-bc64-b637f1244a89   none   swap   sw   0   0



con questa

Codice:
# SWAP
UUID=5c65704a-abb4-4f96-a54e-13bc73b35742 none   swap   sw   0   0

dai
Codice:
sudo gedit /etc/fstab
se hai un altro editor di testo , non so che versione di mint hai, cambia gedit con il nome del tuo editor, fatta la modifica salva il file e chiudilo e riavvia mint
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#7
fatto, ma non è cambiato niente, su korora dice swap non disponibile
Cita messaggio
Grazie da:
#8
Bhe è normale , tuxino ti ha fatto cambiare mint non korora .. aggiungi la stessa cosa al file fstab di korora e riavvia per vedere se dopo korora l'ha.

Codice:
# SWAP
UUID=5c65704a-abb4-4f96-a54e-13bc73b35742 none   swap   sw   0   0
Cita messaggio
Grazie da:
#9
grazie, domani posto il risultato
Cita messaggio
Grazie da:
#10
la swap è attiva, risolto. Mi riprometto di reinstallare tutto dopo opportuni back-up, utilizzando una sola swap, sempre che procedura da voi indicata sia valida per tutti i sistemi. grazie.

(15-02-2016,20:33 )tuxino Ha scritto: mah cè un casino...

tuxino, cosa intendevi dire? le partizioni sugli hard disk?
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)