Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Riparare settori danneggiati hd su Lubuntu su Dell Precision M4300
#1
Wink 
Buonasera,
ho un problema con l'avvio del pc, un DELL PRECISION M4300, sul quale ho installato Lubuntu 15.10 da poco.
il primo giorno tutto ok e, una volta acceso, va alla grande.
Dopo un giorno ha però qualche problema di avvio. Compare la schermata dell con la barra di avvio e poi sembra accendersi completamente ma il monitor resta nero e non si vede nulla.
Sono sicuro che sia acceso ma il monitor è nero.

Faceva la stessa cosa anche prima che c'era installato windows 7 quindi penso sia un problema di hd nel lancio del sistema operativo.

Andando a vedere i dischi mi dice che il disco ha un settore danneggiato.

Penso sia questo il problema. Ho provato a intervenire con hdrecover e con fsck come descritto su web ma non ne vengo a capo.....provo ad allegare screenshot anche delle prove fatte per essere più esplicito.

Se è questo il problema cosa faccio?

Altrimenti?

grazie mille


Allegati Anteprime
                       
Cita messaggio
Grazie da:
#2
Se fosse vero che l'HD ha un settore danneggiato non credo sia un grosso problema.
Comunque in alto a sinistra di Dischi c'è il menù degli SMART TEST, aprilo e leggi/posta che cosa dice.
Io uso gsmartcontrol, ma anche con Dischi ci dovrebbe essere la possibilità di fare un test approfondito.

Per tentare di riparare il fs puoi anche usare gparted live, senza montare le partizioni.
Una volta selezionata la partizione con il tasto dx dal menù, "Controllo".

Se le cose peggiorano, salva tutto quello che interessa ed usa"dd" che dovrebbe marcare i settori danneggiati, mentre te li azzera.
Comunque questo problema potrebbe anche non essere dovuto al disco, ma a qualche altro componente hardware visto che ti succedeva anche con Windows.
Cita messaggio
Grazie da: Marco R , deca1981
#3
i settori danneggiati non si possono riparare, si possono solo marcare come danneggiati affinché non vengano più usati;
la marcatura si fa con la formattazione zerofill (meglio nota come formattazione a basso livello), il che significa che devi prima salvare tutti i dati che ti servono, poi "rasare a zero" l'HDD formattandolo a basso livello con un tool apposito, infine reinstallare il/i sistema operativo/i
Il mio blog: ZEROZEROCENT.BLOGSPOT.COM
LEGGE DI MURPHY: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
VERSIONE QUANTISTICA DELLA LEGGE DI MURPHY: TUTTO VA MALE CONTEMPORANEAMENTE
Cita messaggio
Grazie da:
#4
vedo che non hai un partizionamento "solito", leggo LVM, mapper..... se è una tua scelta allora va bene ma non saprei da che parte dirti di iniziare. se invece decidi di reinstallare, allora io partirei dal bios, impostare il controller disco su AHCI ( credo che ora sia su RAID ), poi con un programma in live per gestire i dischi, gparted va benissimo inizierei con l'impostazione crea tabelle msdos, quindi partizionerei nella solita maniera.
Cita messaggio
Grazie da:
#5
Un solo settore danneggiato non porta nessun problema. Anche perchè bisogna vedere se è logico (riparabile) o fisico (non riparabile). Io controllerei se non è un problema di "superblocco". per questo controllo devi avviare il SO da live/usb e poi con gparted vedi l'indicazione del hdd da controllare (ese. /dev/sda1). Una volta individuato l'indirizzo del hdd dare il comando:
Codice:
sudo fsck ext4 -.v /dev/sdxx

dove sdxx è l'indirizzo del hd individuato in precedenza. Se nella risposta che avrai c'è la dicitura:
Citazione:Il superblocco non poteva essere read o non descrive un corretto ext4
filesystem. Se il dispositivo è valido e contiene realmente un ext4
filesystem (e non swap, ufs o altro ), allora il superblocco
è corrotto, e si potrebbe provare ad eseguire e2fsck con un superblocco alternativo:
allora l'errore è lui. Se così è dai da terminale, sempre da live, il comando:
Codice:
sudo mke2fs -n /dev/sdxx
dove sdxx come abbiamo spiegato prima. Il risultato sarà, per esempio:
Citazione:Superblocco salvati nei blocchi:
32768, 98304, 163840, 229376, 294912, 819200, 884.736, 1.605.632, 2.654.208
a questo punto dai il comando:
Citazione:sudo e2fsck -b indirizzo /dev/sdxx
dove al posto di indirizzo ci metti il primo indirizzo della serie. Poi se ci sono errori te li indica e ti dice se vuoi metterli a posto, naturalmente rispondi si. Se con il primo indirizzo non ci sono errori, bisogna passarli tutti.
Cita messaggio
Grazie da:
#6
grazie a tutti siete gentilissimi....

allego per ora risultato di Smart Test su dischi.....


Allegati Anteprime
   
Cita messaggio
Grazie da:
#7
Se non l'hai fatto, fai un test esteso, scegliendolo da Avvia test automatico.
L'unica cosa che mi lascia perplesso è la temperatura, se fosse arrivata a 68 gradi centigradi, sarebbe un pò troppo alta, ma probabilmente non è successo, forse si sono mischiati con i gradi Farenheit.

Se non risulta niente a carico del disco con il test esteso, non credo che ci sia niente da preoccuparsi, sempre premesso che un HD meccanico ti può lasciare in qualsiasi momento.

Nel resto prova a seguire quanto già detto, tenendo conto che che gparted non può maneggiare volumi LVM e quindi non so se sia applicabile anche quanto scritto da roberto1155.
Cita messaggio
Grazie da:
#8
ok fatto test esteso che allego....

scusate il ritardo ma ieri non sono mai riuscito a visualizzare la schermata, sempre con pc acceso perfettamente......(che accendo e spengo a memoria, letteralmente  con password e invio per accendere o click in basso a destra e invio per spegnere, pazzesco)


Allegati Anteprime
   
Cita messaggio
Grazie da:
#9
ragazzi quindi cosa faccio?

è la scheda video o l'hd?

non posso formattare l'hd e poi reinstallare il so e la facciamo finita??!!

ho però bisogno di istruzioni passo passo....
Cita messaggio
Grazie da:
#10
Al momento apparentemente l'HD non sembra essere particolarmente danneggiato, un solo settore su chissà quanti ...... non fa primavera.
Il mio o altri che ho visto hanno molti più errori del tuo eppure funzionano, anche se non c'è da affidarsene troppo, ma sino a quando vanno .....
Se il test esteso non ha dato grossi errori, la causa potrebbe essere anche la scheda video, la scheda madre, l'alimentazione, le DIMM o una qualsiasi periferica che sta tirando le cuoia.

Quindi è molto difficile dire che cosa possa essere, in casi come questi il secondo indiziato di rigore è la scheda video.
Hai la possibilità di sostituirla con un'altra usata, ma funzionante ?
Puoi provare a scambiare le DIMM o metterne una alla volta ?
Hai fatto una ispezione visiva alla MoBo, ci sono condensatori ingrossati ?
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)