SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Risolto] - Installare Debian 9.3 64 – Mate
#21
Non so come debian o ubuntu gestiscano queste patch ma dovrebbero arrivare con i kernel ( già integrate ) almeno su manjaro e arch è così .. se si vuole disabilitare il kernel-page-table-isolation ( kpti ) si può fare dal kernel con
Codice:
nopti o pti=off


Poi dipende .. tutti gli atm delle banche con winxp sopra li hanno patchati ?
Ma qua si và OT per cui chiudo ..
Cita messaggio
Grazie da:
#22
ciao andrea. premetto che non so nulla delle patch. ritornando al tuo problema, io farei cosi:
staccherei fisicamente il hd con debian. quindi reinstallerei il grub dal sistema che tu vuoi che lo gestisca. ora vedi come funziona il tutto. se ancora hai tempi lunghi nell'avvio, sai che debian non centra nulla, cerca di risolverli. solo quando avrai sistemato il tutto, riparleremo di debian. io quando faccio queste cose tengo sempre a portata di mano >>> rescatux, mi aiuta.
il comando esatto da dare per installare sulla partizione / dovrebbe essere:
sudo grub2-install --force /dev/sdb3 , dove si elenca grub2 che è diverso da grub. per l'update invece va bene il solo grub.


una curiosità, se ubuntu gestisce il grub, PCLinuxOS parte?
Cita messaggio
Grazie da:
#23
si Mario parte e come.
In realtà col grub di Ubuntu sto gestendo:
Ubuntu 16.04 - pclinuxos kde - Win 10 pro - Mint 18303 Cinnamon - Debia 9.04 Mate.
Partono tutte le distro entro tempi ragionevolmente brevi (da 10 a 15 secondi) ad esclusione di Ubuntu che si becca circa 2 minuti, ma poi va bene anche lui.
   
Se hai letto tutta la discussione ci sono alcune incongruenze, credo dovute esclusivamente  a sto benedetto "Spectre mitigation".
Proverò a staccare sdb dove c'é Debian e a reeinstallare il grub di ubuntu.
Mal che vada installerò il grub di ubuntu sulla sua partizione e farò gestire tutto al grub di Debian che andrò ad installare su sda.
ci sentiamo
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#24
Citazione:Codice:
nopti o pti=off
Dove si trova o dove si dovrebbe aggiungere la stringa sopra citata?
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#25
Non si trova la dovete aggiungere voi ai parametri del kernel

Codice:
GRUB_CMDLINE_LINUX_DEFAULT
in
Codice:
/etc/default/grub

e vi aggiungete
Codice:
nopti

quindi salvate e date il classico update-grub ..

Comunque non sto consigliando di disabilitare la patch sia chiaro eh ... per disabilitarlo dovreste vedere un significativo calo di performance consapevoli che disabilitandolo il pc tornerà come prima ma con quei buchi ..
Cita messaggio
Grazie da:
#26
Sempre più difficile...Meno male che a detta di molti DEBIAN è una delle distribuzioni più stabili, che meno aggiornano e tra le più usate...
Cita messaggio
Grazie da:
#27
(22-04-2018,21:37 )Sebastian Ha scritto: Sempre più difficile...Meno male che a detta di molti DEBIAN è una delle distribuzioni più stabili, che meno aggiornano e tra le più usate...

Andrea il problema all'avvio lo ha con Ubuntu.... Tongue
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#28
dando il comando
Codice:
sudo gedit etc/default/grub

Spoiler :
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="800x600x8"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

questo é il mio grub dove esiste la stringa:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

da quello che ho capito, dovrei aggiungere la stringa dopo:   "quiet splash" in maniera da ottenere:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" nopti

oppure dopo : GRUB_CMDLINE_LINUX=""  in maniera da ottenere:

GRUB_CMDLINE_LINUX="" nopti

o in alternativa,  dopo:  GRUB_COMMANDLINE_LINUX    vado a capo
e aggiungo nopti  o semplicemente  pti=off

non vorrei sbagliare la sintassi.
grazie

Edit:
ho trovato anche questo:
https://wiki.ubuntu.com/SecurityTeam/Kno...ndMeltdown
e questo:
https://wiki.ubuntu.com/SecurityTeam/Kno...onControls
dove viee citata anche la possibilità  pti=auto, che mi sembra appropriata per il mio processore amd 64, vedi spoiler:
Spoiler :
apanta@apanta-desktop:~$ sudo dmidecode -t processor
[sudo] password di apanta:
# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.5 present.

Handle 0x0004, DMI type 4, 40 bytes
Processor Information
Socket Designation: CPUSocket
Type: Central Processor
Family: Athlon X2
Manufacturer: AMD              
ID: B2 0F 06 00 FF FB 8B 17
Signature: Family 15, Model 107, Stepping 2
Flags:
FPU (Floating-point unit on-chip)
VME (Virtual mode extension)
DE (Debugging extension)
PSE (Page size extension)
TSC (Time stamp counter)
MSR (Model specific registers)
PAE (Physical address extension)
MCE (Machine check exception)
CX8 (CMPXCHG8 instruction supported)
APIC (On-chip APIC hardware supported)
SEP (Fast system call)
MTRR (Memory type range registers)
PGE (Page global enable)
MCA (Machine check architecture)
CMOV (Conditional move instruction supported)
PAT (Page attribute table)
PSE-36 (36-bit page size extension)
CLFSH (CLFLUSH instruction supported)
MMX (MMX technology supported)
FXSR (FXSAVE and FXSTOR instructions supported)
SSE (Streaming SIMD extensions)
SSE2 (Streaming SIMD extensions 2)
HTT (Multi-threading)
Version: AMD Athlon™ 64 X2 Dual Core Processor 5200+      
Voltage: 1.5 V
External Clock: 200 MHz
Max Speed: 2700 MHz
Current Speed: 2700 MHz
Status: Populated, Enabled
Upgrade: Socket 940
L1 Cache Handle: 0x0005
L2 Cache Handle: 0x0006
L3 Cache Handle: 0x0007
Serial Number: To Be Filled By O.E.M.
Asset Tag: To Be Filled By O.E.M.
Part Number: To Be Filled By O.E.M.
Core Count: 2
Core Enabled: 2
Characteristics:
64-bit capable

apanta@apanta-desktop:~$
suggerimenti sono graditi   At
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#29
la riga è
Codice:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nopti"
            La vita è come uno specchio:ti sorride se la guardi sorridendo.
                                                    Un giorno senza rischio è non vissuto.....                  
PCLinuxOS Mate - Manjaro Mate/Xfce
Cita messaggio
Grazie da: Sebastian , Sebastian
#30
Ho aggiunto alla riga:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
l'ulteriore nopti, in maniera da avere:
Codice:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nopti"
apro un terminale e faccio un:
Codice:
sudo upgrade-grub
Metto la password e vedo l'elenco di tutte le distro e all'ultima riga trovo: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nopti" fatto

esco e riavvio, compare grub, scelgo Ubuntu e stavolta dopo circa 20 secondi passa alla schermata classica di caricamento della live, (vedi in precedenza) ma in effetti passano ancora una novantina di secondi prima che appaia la schermata di login di Ubuntu.
Qualcosa è migliorata ma non come prima ( Ubuntu si avviava in circa 10-12 secondi), tuttavia funziona tutto, anche gli altri s.o., che ora sono tutti più veloci di ubuntu, all'avviamento.
Ho anche fatto :
Codice:
sudo apt-get update
seguito da:
Codice:
sudo apt-get dist-upgrade
notando che è stato installato un nuovo kernel (4.4.0-121-generic), mentre in precedenza c'era il kernel 4.4.0-119,  ma nessuna differenza apprezzabile.
Come ultima cosa, appena possibile, farò come ha suggerito Mario, staccando sdb (dove c'é Debian) dal pc e provando solo con sda (dove ci sono Win10Pro - Ubuntu - PCLinuxOS), per poi fare un update-grub per vedere cosa succede.
Grazie sempre per l'aiuto. At  At
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: