SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Risolto] - Installare Debian 9.3 64 – Mate
#41
Il device che sta impegnando il sistema sembra essere:
Citazione:dev-disk-by\x2duui...429\x2da80f6614b45a.device (9s / 1min 30s)
dove dopo device, tra parentesi si vede il tempo di esecuzione, sempre crescente, per ogni riga successiva.
Dando il comando:
Codice:
sudo blkid
il responso é:
Citazione:apanta@apanta-desktop:~$ sudo blkid
[sudo] password di apanta:
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"

/dev/sda1: UUID="65b01e1a-4e8f-4575-bd7e-4e67dbaa6e56" TYPE="swap" PARTUUID="0000561b-01"

/dev/sda3: LABEL="Win10Pro" UUID="D4845922845907FE" TYPE="ntfs" PARTUUID="0000561b-03"

/dev/sda5: LABEL="Ubuntu16.04" UUID="48ad98ba-ec05-4526-8a61-bd1e0a7383a6" TYPE="ext4" PARTUUID="0000561b-05"

/dev/sda6: LABEL="DatiSSD" UUID="1CD79A8524C94AF2" TYPE="ntfs" PARTUUID="0000561b-06"

/dev/sda7: LABEL="PCLinuxOSKDE" UUID="05ce3c9e-c59a-4e42-8174-d401df931a10" TYPE="ext4" PTTYPE="dos" PARTUUID="0000561b-07"

/dev/sdb1: LABEL="Tera2" UUID="36F4F0B8F4F07B85" TYPE="ntfs" PARTUUID="c5c28a67-01"

/dev/sdb3: LABEL="Debian9.4" UUID="d0d2756d-dbc3-45dd-ad3c-17c21e026d2d" TYPE="ext4" PTTYPE="dos" PARTUUID="c5c28a67-03"

/dev/sdb5: LABEL="Mint18.03cinnamo" UUID="04ac8606-a4e7-414b-8b76-b47fe547603b" TYPE="ext4" PTTYPE="dos" PARTUUID="c5c28a67-05"

/dev/sdc1: LABEL="TERA1" UUID="9C6C09166C08ED38" TYPE="ntfs"
PARTUUID="0000f141-01"
apanta@apanta-desktop:~$

Non noto nessuna corrispondenza con quanto riportato nel file bbot.log.
dove sto sbagliando? nel frattempo la cosa mi intriga sempre più. visto che anche Mint, adesso ritarda come ubuntu (stesso comportamento)
Edit: da Ubuntu, lancio gparted e noto che la swap non è montata.
Mi sto ricordando che quando ho installato Debian, per una frazione piccolissima di tempo é comparso un avviso che la swap sarebbe stata cancellata.
Allora googolando ho trovato:
https://forum.ubuntu-it.org/viewtopic.php?p=4835649
e quì:
https://ubuntuforums.org/archive/index.p...36694.html
da gparted la swap non è montata, mentre ritengo che lo debba essere:
   
sempre da gparted ho montato la swap e fatto un riavvio. niente; editando ancora gparted, la swap é smontata.
Ho dato allora:
Codice:
sudo gedit /etc/fstab
e questo è il risultato:
Citazione:# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=48ad98ba-ec05-4526-8a61-bd1e0a7383a6 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda1 during installation
UUID=24446917-d72d-410d-a429-a80f6614b45a
none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,rw,noauto,exec,utf8  0       0
Ed eccola, la partizione con UUID come da boot.log
Domanda: se nel file fstab vado a sostituire l'uuid ....45a con quello che mi da blkid :
65b01e1a-4e8f-4575-bd7e-4e67dbaa6e56
dovrei risolvere tutto. In pratica si tratta di attribuire un nuovo UUID alla swap, che potrei anche fare da gparted.
potrebbe essere lo stesso problema, ma mi servono conferme per rincuorarmi
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#42
se la partizione di swap ha un uuid diverso, aggiorna quello in fstab con quello che hai trovato con il comando blkid. Ricorda che l'UUID delle partizioni varia se queste vengono p. es. formattate. Ad ogni modifica della partizione (formattazione, ridimensionamento, modifica/cambio del filesystem) il suo UUID cambia.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#43
La cosa si è complicata.
Ho sostituito l'uuid del fstab di ubuntu con l'uuid ricavato dal comando "blkid"
chiuso e riavviato e adesso ubuntu non parte più.  arrivo ad una schermata di login
apanta-desktop login:
metto i miei riferimenti e la password, ma non accade nulla e dopo una serie di movimenti si torna alla riga di login.
Allora ho rimesso il precedente uuid nel fstab di ubuntu, salvo e riavvio, ma é tutto bloccato.
Per fortuna Mint parte.
Allora vado a vedere in Mint il file fstab e trovo lo stesso numero che era in Ubuntu
(24446917-d72d-410d-a429-a80f6614b45a).
faccio un blkid da terminale sotto Mint e trovo :
/dev/sda1: UUID="bc393037-59bc-459a-9b24-32d0011efba9" TYPE="swap" PARTUUID="0000561b-01"
ma su questa riga non c'é il cancelletto di commento all'inizio, mentre nel fstab di ubuntu c'é.

Chiedo: l'UUID é sempre lo stesso, indipendentemente da quale s.o. sto usando, vero?
quindi dovrei cambiare tale numero su tutti i s.o. che ho, ma ho paura di bloccare tutto, come è successo con Ubuntu.

Desidero ancora sapere:
se dovessi cancellare la swap cosa succederebbe (ho abbastanza ram per farlo); basta eliminare la partizione e togliere la riga dal fstab?
se si, va tolta, ovviamente su tutti i s.o. ?

Questa, comunque é la situazione delle mie varie partizioni:
   
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:
#44
Citazione:faccio un blkid da terminale sotto Mint e trovo :
/dev/sda1: UUID="bc393037-59bc-459a-9b24-32d0011efba9" TYPE="swap" PARTUUID="0000561b-01"
ma su questa riga non c'é il cancelletto di commento all'inizio, mentre nel fstab di ubuntu c'é.

Chiedo: l'UUID é sempre lo stesso, indipendentemente da quale s.o. sto usando, vero?
quindi dovrei cambiare tale numero su tutti i s.o. che ho, ma ho paura di bloccare tutto, come è successo con Ubuntu.
L'UUID è uguale per tutte le distro. Mi parli di cancelletto all'inizio riga della partizione swap nel fstab di ubuntu , ma non dovrebbe esserci (la presenza del cancelletto commenta la riga stessa e quindi non viene letta)
magari posta quella porzione di fstab...
Per il problema al login prova ad avviare ubuntu usando un kernel precedente ( mi è capitata la stessa cosa ed era il kernel a creare questo problema).
Se hai ram a sufficienza puoi evitare di usare la swap. Per caso usi un HD SSD? Ss ben ricordo in alcuni post su questo forum si sconsigliava l'uso della swap su ssd, ma attendo conferme.

EDIT:
ti riferisci a questa riga?:
# swap was on /dev/sda1 during installation
in tal caso è corretta, non viene letta perchè è solo un commento che spiega la riga sottostante.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#45
Eccomi,
sono stato in viaggio e posso rispondere solo ora.
Praticamente ho risolto cambiando, come amministratore,  l'UUID della swap su tutti i file  "fstab" presenti in ogni sistema operativo basato su debian  (Debian, Ubuntu, Mint), sostituendo l'uuid esistente con quello scaturito dal comando blkid da terminale.
In pratica il problema è nato al momento dell'installazione quando ho dato, erroneamente, anche l'assenso alla formattazione della swap, anziché proseguire solo con l'allocazione del sistema operativo Debian sdb3.
In questa maniera l'UUID della swap è cambiato e i vari s.o. non la trovavano al momento dell'avvio.
Ora va tutto bene , Ubuntu si avvia in circa 16 secondi, alla stregua di Mint e Debian. PCLinuxOS è l'unico che non ho toccato, in quanto filava e fila come l'olio.
Vado a scrivere risolto.
Un sentito grazie per la fattiva collaborazione a tutti gli amici intervenuti.
"Le avversità spesso ci piegano ma la ns. forza ci risolleva sempre.

Ubuntu 16.04 - Ubuntu 18.04 - MX-Linux 18.2 - Mint 19 Tessa
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: