Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Risolto]Majonix 1: impossibile aggiornare
#1
Salve. Stamane ho cercato di aggiornare Majonix 1 ma si blocca su questa voce:kernel 3.2.0-76. ho dato apt-get install -f ma non cambia. Fatto e rifatto ma sempre uguale. Se serve posto il log del terminale. Grazie dell'aiutino.
Ubuntu Xenial Xerus * 64 bit * DE Gnome Fallback NVIDIA GT240-512 Mb
Majonix 1 / Lubit7 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio
Grazie da:
#2
Sarebbe bene avere l'errore generato e l'elenco dei kernel presenti sul sistema Undecided
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
Grazie da:
#3
Codice:
marconix@marconix-P5Q-PRO:~$ sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti saranno inoltre installati:
 linux-image-3.2.0-76-generic-pae
Pacchetti suggeriti:
 fdutils linux-doc-3.2.0 linux-source-3.2.0 linux-tools
I seguenti pacchetti NUOVI saranno installati:
 linux-image-3.2.0-76-generic-pae
0 aggiornati, 1 installati, 0 da rimuovere e 6 non aggiornati.
2 non completamente installati o rimossi.
È necessario scaricare 0 B/38,5 MB di archivi.
Dopo quest'operazione, verranno occupati 114 MB di spazio su disco.
Continuare [S/n]? s
(Lettura del database... 199798 file e directory attualmente installati.)
Estrazione di linux-image-3.2.0-76-generic-pae (da .../linux-image-3.2.0-76-generic-pae_3.2.0-76.111_i386.deb)...
Done.
dpkg-deb (sottoprocesso): dati: errore interno di lettura di bzip2: "DATA_ERROR"
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare /var/cache/apt/archives/linux-image-3.2.0-76-generic-pae_3.2.0-76.111_i386.deb (--unpack):
lettura breve durante la copia del buffer per dpkg-deb backend su "./lib/modules/3.2.0-76-generic-pae/kernel/sound/i2c/other/snd-ak4117.ko"
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-76-generic-pae /boot/vmlinuz-3.2.0-76-generic-pae
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-76-generic-pae /boot/vmlinuz-3.2.0-76-generic-pae
Si sono verificati degli errori nell'elaborazione:
/var/cache/apt/archives/linux-image-3.2.0-76-generic-pae_3.2.0-76.111_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
marconix@marconix-P5Q-PRO:~$

Questo stasera:

E: /var/cache/apt/archives/linux-image-3.2.0-76-generic-pae_3.2.0-76.111_i386.deb: lettura breve durante la copia del buffer per dpkg-deb backend su "./lib/modules/3.2.0-76-generic-pae/kernel/sound/i2c/other/snd-ak4117.ko"
Ecco fatto. Ora con grub customizer ho ripulito le versioni che non uso, sia ubuntu che majonix.
Temo che il mio pc si avvicini alla fine. Oggi peggio di sempre: quando clicco una qualsiasi scelta, sia programma sia funzione se sento un click nel pc si freeza per circa un minuto poi riprende come nulla fosse, anzi se avevo dato più volte il comando li esegue come richiesto. In più mi è sparito Thunderbird.Non so se le cose siano collegate...
Ubuntu Xenial Xerus * 64 bit * DE Gnome Fallback NVIDIA GT240-512 Mb
Majonix 1 / Lubit7 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio
Grazie da:
#4
Ciao, dunque con grub customizer hai solo eliminato le voci dal menu di grub ma non i kernel presenti nel sistema.
Sembra inoltre che il problema sia legato al modulo della scheda audio attualmente installato sul tuo kernel, quindi direi di procedere così:
  • Ripristina i menu di grubcustomizer (ti basta dare da terminale il comando sudo update-grub);
  • Riavvia ed entra con il penultimo kernel disponibile (segnati su un pezzo di carta la versione);
  • Ora, con synaptic, disinstalla tutti gli altri kernel, ricorda che per ogni versione del kernel le voci sono due (header e image) Fai attenzione a non rimuovere il kernel in uso (quello che ti sei segnato sul pezzo di carta);
  • Riavvia, ora in grub avrai solo un kernel, apri MajoPlus e clicca sui tre pulsanti per la pulizia della cahe di apt e delle liste di apt e, visto che ci sei, elimina i pacchetti non più necessari;
  • Ora esegui da terminale i due classici comandi (sudo apt-get update e sudo apt-get upgrade).

Fammi sapere l'esito
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
Grazie da: nikelius
#5
Purtroppo la mia pulizia totale è stata fatta prima dei tuoi consigli e quindi non posso recuperare nulla. Ho tentato d'installare  il kernel 3.2.0-74. Ora vedo il risultato...
EDIT: nulla, sembrava che in modalità provvisoria installasse e riparasse i pacchetti danneggiati ma dopo il riavvio sono come prima e non posso seguire la tua procedura perché non saprei quale kernel montare.
RI EDIT: ho installato il kernel - a caso- 3.2.0-49 e reinstallato il funzionante 3.2.0-75, dato update e upgrade.Riavviato. Funzia con la v. 3.2.0-75 e quindi eliminato la v. 3.2.0-49 e pulito il tutto. Bene, ora funzia....Accidenti ho ridato aggiornamenti ed ora mi manca un'altra lib. per wine-compholio. Vabbe' non mi sembra grave. Oserei scriver Risolto. Grazie Dukko.
Ubuntu Xenial Xerus * 64 bit * DE Gnome Fallback NVIDIA GT240-512 Mb
Majonix 1 / Lubit7 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio
Grazie da:
#6
Di nulla, wine-compholio è usata da pipelight per i plugin flash e Unity3D, se mi dici l'errore vediamo di risolvere anche quello.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
Grazie da:
#7
Ho dato apt-get install -f e update / upgrade ed ora è a posto. Grazie.
Ubuntu Xenial Xerus * 64 bit * DE Gnome Fallback NVIDIA GT240-512 Mb
Majonix 1 / Lubit7 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio
Grazie da:
#8
Ok, meglio così. Tongue
Puoi mettere [RISOLTO] nel titolo del thread At
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
Grazie da:


Vai al forum: