Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
SOS: Errore post - Installazione Ubuntu 18
#1
Salve a tutti.
Ho un hp15 modello r212nl. Seguendo le guide online avevo creato un dual boot WIndows10 - ubuntu 17. Tutto funzionava bene. Poi ho avuto la brillante idea di fare quanto segue.
Ho creato una chiavetta bootable con ubuntu 18 (ultima versione). Ho inserito la chiavetta e fatto l'installazione selezionando la voce "rimuovi ubuntu 17 e installa ubuntu 18". L'installazione va a buon fine ma poi quando avvio arrivo nel grub rescue.

Dal boot rescue digitando "set" vedo che root = hdo5 cioè una partizione efi (fat32).
allora digito
set root = hd0,7
set prefix=(hd0,7)/boot/grub
insmod normal e qui mi da l'errore [error file boot/grub/i386-pc/not found]. 

Osservazioni:
1) non accedo piu nemmeno a Windows perche rimango nel boot rescue
2) Posso solo accedere dalla live ubuntu
3) Ho installato ubuntu in modalità Legacy Bios
4) Dall'errore si vede che normal.mod viene ricercato sotto la cartella i386-pc mentre da live io vedo che sta sotto x86_64-efi
5)Le partizioni sono:
   dev/sda1 [ntfs] [riservato per il sistema]
   dev/sda2  [ntfs] [OS]
   dev/sda4  [extended]
             dev/sda5 [fat32]  [flag=boot,esp]
             dev/sda6 [ext4] [root ubuntu]


edit esabatad: discussione spostata in Installazione e Disinstallazione
Cita messaggio
Grazie da:
#2
forse boot repair potrebbe risolvere https://sourceforge.net/p/boot-repair/home/it/
Cita messaggio
Grazie da:
#3
(13-08-2018,10:22 )maxbigsi Ha scritto: forse boot repair potrebbe risolvere https://sourceforge.net/p/boot-repair/home/it/

Ho provato ma quando riavvio torna sul grub rescue
Cita messaggio
Grazie da:
#4
puoi postare una immagine di gparted? come mai essendo in legacy il flag boot è impostato su sda5?
Cita messaggio
Grazie da:
#5
se avevi prima l'installazione con l'avvio gestito da efi ( win ed ubu ) se ora hai hai installato in legacy è normale che non ti si avvii più nulla. una immagine come ti ha richiesto maxbigsi direi che è obbligatoria per dirti cosa fare.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)