Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Scanner su porta parallela non riconosciuto
#1
Buonasera al forum At
Ho esitato parecchio prima di iniziare questa discussione...ma poi mi sono dovuta arrendere all'evidenza: Mint 17.1 non vede lo scanner. Ho rifatto tutta la procedura suggeritami da Luciano ai tempi di Mint 15, ma con la release 17 non funziona
Pensando che magari poteva essere un problema di Kernel troppo recente, ho provato anche ad installare Mint 13 (anch'essa una LTS) ma niente da fare anche così.
Perchè l'UNICA distro che riconosce lo scanner è fuori supporto???
Ho letto tutto quello che ho trovato in rete in fatto di suggerimenti e tecniche varie per installare manualmente lo scanner, ma finora non ho ottenuto alcun risultato;quando lancio sudo xsane non succede nulla, poi quando chiudo la finestra che dice di non aver trovato alcuno scanner......il medesimo fa rumore e si riposiziona. Allora dov'è il problema?
Ho installato Gimp, libieee1284, sane e xsane, simplescan, cosa mi sono dimenticata?
Si accettano suggerimenti: giuro che li proverò tutti......anche i più strani Wink
Vi ringrazio per la pazienza e vi auguro una buona serata Tux
  Se leggi dimentichi -Se scrivi ricordi - Se fai IMPARI  
[Immagine: http://i57.tinypic.com/120ou0y.jpg] [Immagine: http://i61.tinypic.com/jpwzk7.jpg]
Cita messaggio
Grazie da:
#2
At eccomi qua... come ti avevo promesso ho rivisto tutta la situazione e "forse"
ho trovato una possibile soluzione Sfascio scherzo naturalmente Blush

piccola premessa, mi pare di capire che bene o male lo scanner ti viene comunque riconosciuto anche
su mint 17.1 ( che presumo tu abbia ancora installato) anche se non riesci a usare xsane...
potremo iniziare con una verifica
colleghi lo scanner e posizioni un foglio qualsiasi da copiare e apri il terminale e digita

Codice:
sudo scanimage --format=tiff > test.tiff

e vedi il risultato... se non ti da errore (e naturalmente se parte) ti dovresti ritrovare un file test.tiff nella tua home
altrimenti posta il messaggio di errore

fai anche la seguente verifica sia su mint 15 che su mint 17
devi cercare se sono presenti i seguenti files (ti indico il percorso completo )
Citazione:/usr/lib/sane/libsane-canon_pp.a

/usr/lib/sane/libsane-canon_pp.so
Cita messaggio
Grazie da:
#3
Ciao Luciano, scusa il ritardo ma avevo voluto provare anche Extremamint............e ho combinato il solito pasticcio! Ma perchè quando installo una distro su dev/sda6 poi sparisce il boot (che si trova su dev/sda2?)
Tutte le volte devo usare Boot repair.
Comunque, come puoi vedere dalla foto, non ho risolto nemmeno con i comandi che mi hai suggerito.


Allegati Anteprime
   
  Se leggi dimentichi -Se scrivi ricordi - Se fai IMPARI  
[Immagine: http://i57.tinypic.com/120ou0y.jpg] [Immagine: http://i61.tinypic.com/jpwzk7.jpg]
Cita messaggio
Grazie da:
#4
Quando installi una nuova distro devi far attenzione a dove ti chiede di installare il bootloader e indicargli la stessa partizione in cui stai installando il nuovo SO (nel tuo caso dev/sda6), altrimenti ogni volta ti sovrascrive l'MBR e il grub di Mint 17(?) che vi risiede.
Cita messaggio
Grazie da: paola
#5
(23-01-2015,10:29 )luciano Ha scritto: At  eccomi qua... come ti avevo promesso ho rivisto tutta la situazione e "forse"
ho trovato una possibile soluzione  Sfascio   scherzo naturalmente  Blush

piccola premessa, mi pare di capire che bene o male lo scanner ti viene comunque riconosciuto anche
su mint 17.1  ( che presumo tu abbia ancora installato) anche se non riesci a usare xsane...
potremo iniziare con una verifica
colleghi lo scanner e posizioni un foglio qualsiasi da copiare e apri il terminale e digita



Codice:
sudo scanimage --format=tiff > test.tiff

e vedi il risultato... se non ti da errore (e naturalmente se parte) ti dovresti ritrovare un file test.tiff nella tua home
altrimenti posta il messaggio di errore

fai anche la seguente verifica sia su mint 15 che su mint 17
devi cercare se sono presenti i seguenti files (ti indico il percorso completo )


Citazione:/usr/lib/sane/libsane-canon_pp.a

/usr/lib/sane/libsane-canon_pp.so
Rieccomi qui: ho provato a dare i comandi di cui sopra anche dentro Mint 15 ed i file......................non ci sono nemmeno lì! Sono davvero perplessa: eppure con Mint 15 lo scanner funziona (con quei semplici settaggi da te suggeriti mesi fa).
Ho provato anche con Mint 13 (pensando che magari un kernel più datato fosse meglio) ma non c'è proprio niente da fare. Ti mando un'immagine di synaptic da dove si nota che "libsane" e derivati ci sono. Disperato  Undecided  Sfascio


Allegati Anteprime
   
  Se leggi dimentichi -Se scrivi ricordi - Se fai IMPARI  
[Immagine: http://i57.tinypic.com/120ou0y.jpg] [Immagine: http://i61.tinypic.com/jpwzk7.jpg]
Cita messaggio
Grazie da:
#6
per quanto riguarda

Codice:
/usr/lib/sane/libsane-canon_pp.a

/usr/lib/sane/libsane-canon_pp.so
dovevi solo "vedere" se sono presenti, puoi farlo con il gestore dei file
cliccando sulle varie cartelle... io ti ho indicato il percorso quindi devi partire
cercando la cartella usr quindi lib e infine sane e li vedi se ci sono le librerie libsane-canon__pp.a e libsane-canon__pp.so
fai il controllo come ho già scritto sia su mint15 che 17
Cita messaggio
Grazie da:
#7
Et voilà, sono su Mint 17.1 e queste sono le cartelle che trovo, però non riesco a scompattare.
Inoltre ti mando anche un'altra immagine, magari può essere utile a capire....


Allegati Anteprime
       
  Se leggi dimentichi -Se scrivi ricordi - Se fai IMPARI  
[Immagine: http://i57.tinypic.com/120ou0y.jpg] [Immagine: http://i61.tinypic.com/jpwzk7.jpg]
Cita messaggio
Grazie da:
#8
E questo è il contenuto della cartella "sane" dentro Mint 15.
Non è che per caso, invece di aggiungere....devo togliere? Infatti dentro Mint 15, quella cartella scura chiamata "libsane-canon_pp.a" (che vedo dentro Mint 17) non c'è.....e lo scanner funziona benissimo. Undecided


Allegati Anteprime
   
  Se leggi dimentichi -Se scrivi ricordi - Se fai IMPARI  
[Immagine: http://i57.tinypic.com/120ou0y.jpg] [Immagine: http://i61.tinypic.com/jpwzk7.jpg]
Cita messaggio
Grazie da:
#9
ok ho avuto una "parziale " conferma della mia teoria, si dovrebbe trattare di problemi
di librerie anche se io mi aspettavo che nella versione funzionante (mint 15) avresti trovato i due files...
comunque puoi provare a togliere il file libsane-canon_pp.a, così come tu stessa hai ipotizzato,
e provare lo scanner (sempre come amministratore con "sudo xsane")
Se non dovesse funzionare prova ad aprire il terminale e digita
Codice:
sudo ldconfig
vedi cosa ti restituisce e riprova lo scanner.
Cita messaggio
Grazie da:
#10
Innanzitutto buona domenica!
E poi, scusa  la stupidità della domanda: ma come lo tolgo il file  libsane-canon_pp.a?
Non esiste l'opzione di rimozione e se lo apro come amministratore mi dice "tipo di archivio non supportato".
E quindi come faccio? Immagino ci saranno dei comandi da dare sul terminale....


Allegati Anteprime
   
  Se leggi dimentichi -Se scrivi ricordi - Se fai IMPARI  
[Immagine: http://i57.tinypic.com/120ou0y.jpg] [Immagine: http://i61.tinypic.com/jpwzk7.jpg]
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)