SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Synaptic mancato avvio
#1
Buongiorno a tutti.
Come da titolo synaptic non si avvia più (la passwd è giusta) e non riesco a fare aggiornamenti, ho provato ad aprire configure your computer ma non parte nemmeno quello da il seguente report:
Codice:
Il programma "drakconf" si è interrotto per questo errore:

 Could not locate symbol webkit_web_view_new at /usr/lib/libDrakX/mygtk3.pm line 621.
 Perl's trace:
 drakbug::bug_handler() called from /usr/lib/perl5/5.22.3/Carp.pm:166
 Carp::croak() called from /usr/lib/perl5/vendor_perl/5.22.3/x86_64-linux-thread-multi/Glib/Object/Introspection.pm:67
 Glib::Object::Introspection::__ANON__() called from /usr/lib/libDrakX/mygtk3.pm:621
 mygtk3::_gtk__WebKit_WebView() called from /usr/lib/libDrakX/mygtk3.pm:610
 mygtk3::_gtk__WebKit2_WebView() called from /usr/lib/libDrakX/mygtk3.pm:122
 mygtk3::_gtk() called from /usr/lib/libDrakX/mygtk3.pm:59
 mygtk3::gtknew() called from /usr/libexec/drakconf:626

Tema utilizzato: Blue-Submarine

Please report this to the PCLinuxOS forum.
prima di questo guaio ho avuto dei problemi a far partire il pc si accendeva e ripartiva da solo facevo il login entravo poi si spegneva e ripartiva ho cambiato l'alimentatore (vecchio) e sembra che questo problema si sia risolto, ma sono sorti questi nuovi. Un grazie a tutti quelli che hanno qualche consiglio. Il sistema è pclinuxos x64 mate 2019 kernel 5.2.5. Ho provato anche da terminale:
Codice:
[dumaron@localhost ~]$ synaptic
/usr/libexec/synaptic: error while loading shared libraries: /usr/lib64/libelf.so.1: file too short
[dumaron@localhost ~]$
Cita messaggio
Grazie da:
#2
Ciao
Hai provato a fare un aggiornamento da terminale:
comandi uno alla volta seguiti da invio
Codice:
su
apt-get update
apt-get dist-upgrade


vedi cosa rispondono e posta errori se ci sono.
            La vita è come uno specchio:ti sorride se la guardi sorridendo.
                                                    Un giorno senza rischio è non vissuto.....                  
PCLinuxOS Mate - Manjaro Mate/Xfce
Cita messaggio
Grazie da:
#3
per chiarezza, con su , invio, pswd si diventa amministratore. i comandi vanno poi scritti dopo il #
un esempio, synaptic va avviato come amministratore quindi:
su
invio
password
invio
scrivere il comando. nel caso synaptic. una volta terminato il lavoro scrivere:
exit
invio. ora puoi chiudere il terminale.
Cita messaggio
Grazie da:
#4
Codice:
[dumaron@localhost ~]$ su
Password:
[root@localhost dumaron]# apt-get update
apt-get: error while loading shared libraries: /usr/lib64/libelf.so.1: file too short
[root@localhost dumaron]# apt-get dist-upgrade
apt-get: error while loading shared libraries: /usr/lib64/libelf.so.1: file too short
[root@localhost dumaron]#
Codice:
[dumaron@localhost ~]$ su
Password:
[root@localhost dumaron]# synaptic
/usr/libexec/synaptic: error while loading shared libraries: /usr/lib64/libelf.so.1: file too short
[root@localhost dumaron]#
Buongiorno a tutti adesso capisco che i problemi precedenti erano dovuti a questo fatto ho dovuto fare tre o quattro reinstallazioni.
Cita messaggio
Grazie da:
#5
Citazione:Buongiorno a tutti adesso capisco che i problemi precedenti erano dovuti a questo fatto ho dovuto fare tre o quattro reinstallazioni.
quindi adesso funziona?
Cita messaggio
Grazie da:
#6
No no non funziona come vedi dai codici del terminale , intendevo che ho fatto le reinstallazioni precedenti a questa per lo stesso problema il pc si riavviava da solo forse per l'alimentatore guasto, causa filo messo male si era arrostito ma il tecnico, tagliati alcuni fili aveva detto che funzionava, adesso se questo problema si potesse risolvere non volevo più fare installazioni. Sono andato a cercare i file /usr/lib64/.... scritti nel terminale e sono completamente vuoti. Ma mi viene un dubbio all'inizio della discussione quando scrivo che ho tentato di aprire configure your computer e si visualizza la schermata che ho postato ieri alle 07,23 nella quarta riga si legge:
Codice:
drakbug::bug_handler() called from /usr/lib/perl5/5.22.3/Carp.pm:166

non sarà , scrivo da profano, un bug?
Cita messaggio
Grazie da:
#7
vediamo se arriva qualche suggerimento >>> https://www.pclinuxos.com/forum/index.ph...msg1279983
per curiosità, che tema di icone stai usando?
Cita messaggio
Grazie da:
#8
Mate-Faenza-Dark
Cita messaggio
Grazie da:
#9
Il programma ti dice che il file /usr/lib64/libelf.so.1 e' troppo corto... in altre parole e' troncato. Secondo me le cause possono essere due: hai la root piena (controlla con df), e quindi il file in fase di aggiornamento non e' stato scritto correttamente, oppure c'e' stata una interruzione durante un aggiornamento.

Il file in questione e' in realta' un link logico allla libreria libelf-0.176.so

Codice:
ls -l /usr/lib64/libelf.so.1
/usr/lib64/libelf.so.1 -> libelf-0.176.so
ls -l /usr/lib64/libelf-0.176.so
-rwxr-xr-x 1 root root 100784 lug  9 17:06 /usr/lib64/libelf-0.176.so

Come vedi, li file non e' vuoto, come nel tuo caso.  Puoi provare a reinstallare il file, che appartiene al pacchetto

Codice:
rpm -qf /usr/lib64/libelf.so.1
lib64elfutils1-0.176-1pclos2019

Si farebbe via apt-get, ma a quanto pare non funziona perche' manca proprio quella libreria. Puoi provare a scaricarti direttamente il file rpm dal sito nluug.nl, ed installarlo via rpm, ma potrebbe poi mancare un'altra libreria, ed avanti cosi'... forse la soluzione piu' semplice e' di re-installare.

Ciao, Mauro
CPU: Intel 6-Core i7-5820K (Haswell rev.2)
nVidia GeForce GTX 750 (drv 430.40),  16GB DDR4 RAM
‎Intel C610/X99 HD Audio / Intel I210 Gigabit Network
Supermicro C7X99-OCE
KDE Plasma:5.16.4 Frameworks:5.61.0 Apps:19.08.0
X.org:1.20.5 Qt:4.8.7/5.12.4
Kernel 5.2.10-pclos1 (gcc 9.2.0)
Cita messaggio
Grazie da:
#10
Codice:
[dumaron@localhost ~]$ df
File system     Dim. Usati Dispon. Uso% Montato su
/dev/root        39G  7,3G     30G  20% /
/dev            3,9G 1008K    3,9G   1% /dev
none            3,9G   62M    3,8G   2% /dev/shm
/dev/sda3        63G  3,4G     60G   6% /home
none            3,9G     0    3,9G   0% /var/run/user/500
/dev/sdb1       477G  164G    314G  35% /media/96BC-50263
[dumaron@localhost ~]$
No la root, per quanto ne capisco, non mi sembra piena. Come si installa un pacchetto rpm? Occorre un programma in particolare? Ma poi non posso installare niente. Mi sarebbe venuta un idea se io copiassi il pacchetto da live su una usb,elimino quello che non funziona dal file system e ci incollo il nuovo?
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)