Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Tabella Pivot - Grave Bug su Libreoffice Calc 5
#1
Ciao a Tutti, su indicazione di Salvatore Gorgone e del Prof. Cantaro conosciuti ieri al Linux Day, vi sottopongo qui sul Forum il bug che ho  riscontrato su Libreoffice Calc per testarne il comportamento su altre piattaforme e quindi sollecitarne una risoluzione.

Il problema riguarda i "Totali parziali" di un "Campo Dati" di una Tabella Pivot.
In pratica dopo aver creato la Tabella Pivot con dei Tolali parziali in un "Campo Dati", aprendo la schermata di "Modifica il layout" e cliccando su "OK" i Totali parziali sulla Tabella Pivot spariscono senza aver modificato nulla!

Come attivare i Tolali parziali? Per attivare i Totali parziali della colonna "Campo Dati" aprire il menù a tendina cliccando col tasto destro del mouse sulla Tabella Pivot -> quindi "Modifica il layout" e doppio click sul Campo Riga di cui si vogliono attivare i Totali parziali.

Vi do anche un file di esempio da testare (e per capire meglio il problema): 
1) Click dx sulla Tabella Pivot
2) Nel menù a tendina scegliere "Modifica il layout..."
3) Cliccare su OK
4) L'attributo SOMMA del Campo A è scomparso!

Ho fatto prove su Win XP e Win 8 e dalla versione 4.3 alla 5.0 il problema si presenta. L'unica immune è la 4.2


Potete provare se a Voi assume lo stesso comportamento?

Grazie Smile

p.s. per trovare vecchie versioni Libreoffice qui trovate l'archivio
Cita messaggio
Grazie da:
#2
In questo momento non ho modo di verificare,
Intanto però se vuoi puoi verificare se il bug è noto cercando qui: https://bugs.documentfoundation.org//
Puoi inoltre segnalare il bug seguendo questa guida: https://wiki.documentfoundation.org/QA/BugReport/it
Chi sa capire tutto è molto infelice (Maksim Gor'kij)
[Immagine: http://www.istitutomajorana.it/forum2/at...p?aid=7740]
Cita messaggio
Grazie da: giova_sardisco
#3
Il bug NON è noto e iniziai la sua segnalazione alla comunità italiana Libreoffice a Gennaio 2015. Non ricevetti alcuna risposta né per fare dei test, né per aiutarmi ad inoltre la segnalazione su Bugzilla Scappo
Confido in un maggior riscontro qui Smile
Cita messaggio
Grazie da:
#4
Ciao, Giova(nni?) ti vorrei aiutare, ma....

Io ho Libre Office 4.4.3.2 su Linux MINT.

Se faccio click destro sulla tabella Pivot ecco il menù mi appare:
   

sostanzialmente non mi appare "Modifica il layout..."

sono io che sbaglio?
Ciao Smile
Cita messaggio
Grazie da:
#5
Ciao,
Con LibreOffice 5 in ambiente Windows.
Cliccando su Modifica il layout... si apre la relativa finestra e viene selezionata automaticamente la cella A1. Cliccando su Ok si verifica quello che dicevi tu.

Per ulteriore controllo ho provato con OpenOffice 4 ed il problema non si verifica.

@esabatad Devi cliccare con il pulsante destro del mouse dentro la tabella.
Chi sa capire tutto è molto infelice (Maksim Gor'kij)
[Immagine: http://www.istitutomajorana.it/forum2/at...p?aid=7740]
Cita messaggio
Grazie da:
#6
ok grazie.
domani provo.
Cita messaggio
Grazie da:
#7
Ho scritto ad Italo Vignoli (responsabile LibreOffice Italia) che, prontamente mi ha risposto:

Il bug è noto, e immagino ci stiano lavorando in funzione del rilascio
di LibreOffice 5.1, visto che lo hanno già testato con la nuova versione.

https://bugs.documentfoundation.org/show...i?id=93263
Cita messaggio
#8
(28-10-2015,23:46 )Antonio_Cantaro Ha scritto: Ho scritto ad Italo Vignoli (responsabile LibreOffice Italia) che, prontamente mi ha risposto:

Il bug è noto, e immagino ci stiano lavorando in funzione del rilascio
di LibreOffice 5.1, visto che lo hanno già testato con la nuova versione.

https://bugs.documentfoundation.org/show...i?id=93263

Grazie infinite Professore! Grazie della pronta risposta della comunità!
Ci spero tanto che ciò si realizzi, sono anni che ne soffro.
Il mio primo Linuxday fin ora è stato veramente proficuo Smile
Cita messaggio
Grazie da:


Vai al forum: