Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu 16.04 no supporto driver proprietari AMD
#1
Canonical ha recentemente confermato una notizia di portata storica per la distribuzione, i driver AMD Catalyst fglx saranno considerati deprecati e non verranno ufficialmente supportati o introdotti su Ubuntu 16.04 LTS, il team che presiede all'implementazione del progetto raccomanda agli utenti che utilizzano schede video AMD di passare ai driver Open Aource AMDGPU o ai Radeon.

Questa decisione sarebbe stata presa a seguito di una lunga discussione tra gli sviluppatori di Ubuntu che avrebbero affrontato non poche difficoltà nell'adattare i driver fglx a Xenial Xerus. I lavori per il backporting del codice di Linux 4.5 hanno permesso infatti di ottenere un buon supporto per i driver Open Source AMDGPU e per i Radeon, tuttavia per fglx i problemi si sarebbero rivelati insormontabili con la conseguenza di escludere il supporto ufficiale per gli AMD Catalyst.

Nel momento in cui l'utente andrà ad aggiornare la propria versione di Ubuntu alla nuova release Long Term Support il pacchetto fglrx e il file xorg.conf verranno eliminati dal sistema. La distribuzione si occuperà poi di fornire i nuovi driver che sono già presenti nei repository. L'utilizzatore non si accorgerà del cambiamento in considerazione del fatto che i driver AMDGPU garantiscono il supporto anche alle schede video AMD più recenti.

Per essere sicuri che Ubuntu sia adatta alla propria Graphics Processing Unit AMD è sempre possibile testare il funzionamento da Live CD prima dell'installazione definitiva. In questo modo sarà possibile capire se il proprio hardware è pienamente compatibile con i nuovi driver.

Articolo tratto da http://blog.html.it/11/03/2016/ubuntu-16...etari-amd/

Vedere anche

https://tjaalton.wordpress.com/2016/03/1...ntu-16-04/

e https://wiki.ubuntu.com/XenialXerus/ReleaseNotes#fglrx
Cita messaggio
Grazie da: esabatad , ex_machina , eu66
#2
Grazie della info, non la sapevo questa cosa. Da possessore di scheda video integrata AMD Radeon HD 8570D, dovrò senz'altro approfondire.  Sfascio
Distro: Ubuntu 16.04 LTS x86_64 -- DE: MATE 1.12.1
Cita messaggio
Grazie da:
#3
Tecnicamente sono "deprecati", poi uno se vuole installarseli lo può fare benissimo come si faceva in passato. AMD non è nota per rilasciare schede grafiche amiche di Linux, motivo per cui in passato i driver proprietari erano la scelta "meno peggio", i driver open mi hanno fatto friggere il disco fisso 4 anni fa con ubuntu 12.04. Ora invece piano piano, almeno non su schede nuove, la situazione si è ribaltata, quindi non credo che ne sentiremo la vacanza. Nel dubbio, per chi prevede di usare Linux, mai e poi mai AMD.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)