Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu 17.04 non rileva reti Wi-Fi
#1
Salve, sono un novellino curioso di scoprire e sperimentare un mondo aperto e personalizzabile come quello di Linux. Ho installato Ubuntu in Dual-Boot con Windows 10. Tutto fila liscio se non fosse che da giorni ho problemi con la scheda Wireless, una Broadcom BCM4313 802.11. Fortunatamente l'ethernet funziona e così posso continuare a navigare. A chi potesse interessare, ho provato diverse volte ad installare dal terminale il driver b43 ma nulla, non riesco a rilevare le reti. digitando il comando lshw questo è il risultato:
 
*-network
description: Wireless interface
product: BCM4313 802.11bgn Wireless Network Adapter
vendor: Broadcom Limited
physical id: 0
bus info: pci@0000:04:00.0
logical name: wlp4s0
version: 01
serial: 4e:23:be:b6:e3:92
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) latency=0 multicast=yes wireless=IEEE 802.11
resources: irq:18 memory:f3900000-f3903fff


Ho provato persino ad installare il driver proprietario dal sito ufficiale della Broadcom tramite pacchetto tar.gz. Ecco il dialogo del terminale:
matty95015@matty95015-Lenovo-Z580:~$ sudo su
[sudo] password di matty95015:
root@matty95015-Lenovo-Z580:/home/matty95015# cd eh
root@matty95015-Lenovo-Z580:/home/matty95015/eh# make
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: ingresso nella directory "/usr/src/linux-headers-4.10.0-33-generic"
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  CC [M]  /home/matty95015/eh/src/wl/sys/wl_cfg80211_hybrid.o
/home/matty95015/eh/src/wl/sys/wl_cfg80211_hybrid.c:239:12: error: ‘IEEE80211_BAND_2GHZ’ undeclared here (not in a function)
  .band   = IEEE80211_BAND_2GHZ,  \
          


"Ometto il resto del log perchè superava del doppio i caratteri consentiti ma dubito che ci fossero informazioni cruciali per la
                                           risoluzione del problema."




scripts/Makefile.build:294: set di istruzioni per l'obiettivo "/home/matty95015/eh/src/wl/sys/wl_cfg80211_hybrid.o" non riuscito
make[2]: *** [/home/matty95015/eh/src/wl/sys/wl_cfg80211_hybrid.o] Errore 1
Makefile:1524: set di istruzioni per l'obiettivo "_module_/home/matty95015/eh" non riuscito
make[1]: *** [_module_/home/matty95015/eh] Errore 2
make[1]: uscita dalla directory "/usr/src/linux-headers-4.10.0-33-generic"
Makefile:159: set di istruzioni per l'obiettivo "all" non riuscito
make: *** [all] Errore 2
root@matty95015-Lenovo-Z580:/home/matty95015/eh# make install
install -D -m 755 wl.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless
install: impossibile eseguire stat di 'wl.ko': File o directory non esistente
Makefile:168: set di istruzioni per l'obiettivo "install" non riuscito
make: *** [install] Errore 1


Ho digitato il comando iwconfig, il risultato:
root@matty95015-Lenovo-Z580:/home/matty95015/eh# iwconfig
lo        no wireless extensions.

enp3s0    no wireless extensions.

wlp4s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off


e anche il comando rfkill list:
root@matty95015-Lenovo-Z580:/home/matty95015/eh# rfkill list
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: no
4: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no


Se apro windows 10 il wifi funziona correttamente, non si tratta di wifi disattivato tramite tastiera. Ho esposto tanti più dettagli possibili per far capire a chi legge che ho spulciato guide di ubuntu e forum di ogni genere provandole tutte senza concludere nulla:il driver c'è, linux riconosce la scheda wireless senza apparenti problemi se non quello dell'impossibilità di rilevare alcuna rete wireless in zona nonostante il modem si trovi a mezzo metro di distanza dalla sede. Chiunque abbia un'idea, la esponga, potrebbe essere molto d'aiuto.
Cita messaggio
Grazie da:
#2
una idea purtroppo non l'ho, però mi sento di dirti che non è linux che non riconosce la tua scheda ma il tuo sistema operativo. non esiste solo ubuntu, lui è uno dei molti. ciao
Cita messaggio
Grazie da:
#3
vedi questa
https://forum.ubuntu-it.org/viewtopic.ph...9#p4887769
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#4
(31-08-2017,19:48 )dxgiusti Ha scritto: una idea purtroppo non l'ho, però mi sento di dirti che non è linux che non riconosce la tua scheda ma il tuo sistema operativo. non esiste solo ubuntu, lui è uno dei molti. ciao

Già infatti credo che dopo Ubuntu passerò a debian, visto che ho già provato Fedora.
Cita messaggio
Grazie da:
#5
Ciao,giusto una curiosità:il tuo sistema non vede proprio alcuna rete(non legge gli ssid)o tenta di connettersi all'infinito senza riuscirci?
Cita messaggio
Grazie da:
#6
Photo 
(01-09-2017,10:28 )albertone Ha scritto: Ciao,giusto una curiosità:il tuo sistema non vede proprio alcuna rete(non legge gli ssid)o tenta di connettersi all'infinito senza riuscirci?

Nono proprio non visualizza alcuna rete WIFI. in alegato lo screen con il network manager predefinito di ubuntu[attachment=10674]
Cita messaggio
Grazie da:
#7
Photo 
   
(01-09-2017,10:28 )albertone Ha scritto: Ciao,giusto una curiosità:il tuo sistema non vede proprio alcuna rete(non legge gli ssid)o tenta di connettersi all'infinito senza riuscirci?

Nono proprio non visualizza alcuna rete WIFI. in alegato lo screen con il network manager predefinito di ubuntu
Cita messaggio
Grazie da:
#8
(31-08-2017,21:50 )tuxino Ha scritto: vedi questa
https://forum.ubuntu-it.org/viewtopic.ph...9#p4887769

Letta e applicata, nessun risultato
Cita messaggio
Grazie da:
#9
Ciao
Se nella schermata postata vai in modifica connessioni cosa dice?
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....
Cita messaggio
Grazie da:
#10
Prova questi due comandi e vedi se appaiono connessioni wifi disponibili.

Il primo
Codice:
sudo service nerwork-manager restart
Il secondo
Codice:
sudo systemctl restart network-manager.service
Non darli tutti e due insieme, prima uno--> verifica se ci sono connessioni wifi, poi prova l'altro.
Poi dicci quale dei due ha funzionato (se ha funzionato).
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)