Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu e Qualcomm Atheros ar9285 [Risolto]
#1
Ho un Vaio vpcea3d4e, con la scheda wireless in oggetto.
Sia con win 7 che con Ubuntu 14.04, la scheda, a volte perde il segnale.
Disabilitando e riabilitando "Funzioni di rete" il segnale torna.
Qualcuno può aiutarmi?
Cita messaggio
Grazie da:
#2
È solo un ipotesi,nel ruoter prova a cambiare il canale radio.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#3
Il driver è supportato da Ubuntu, anche se è certificato solo in alcuni hardware

http://www.ubuntu.com/certification/cata...8c%3A002b/:

i driver a seconda della versione dovrebbero essere questi :

https://wiki.debian.org/it/ath9k

Quindi potrebbe essere un problema come quello indicato sopra.
Oppure un bug che persiste dalla 12.04, ma che pare affligga anche la 14.04 :

https://bugs.launchpad.net/ubuntu/+sourc...ug/1251256
Cita messaggio
Grazie da:
#4
(05-10-2015,17:26 )supertuxkart Ha scritto: Il driver è supportato da Ubuntu, anche se è certificato solo in alcuni hardware

http://www.ubuntu.com/certification/cata...8c%3A002b/:

i driver a seconda della versione dovrebbero essere questi :

https://wiki.debian.org/it/ath9k

Quindi potrebbe essere un problema come quello indicato sopra.
Oppure un bug che persiste dalla 12.04, ma che pare affligga anche la 14.04 :

https://bugs.launchpad.net/ubuntu/+sourc...ug/1251256
Premesso che il problema lo riscontro anche con win7, fortunatamente la connessione è stabile. Solo raramente perde il segnale.
Sul forum di ubuntu mi hanno consigliato questo:
Prova a fare un tentativo di connessione dando i seguenti comandi uno per volta
sudo rmmod ath9k
sudo modprobe ath9k nohwcrypt=1
Se vedi che la situazione migliora allora aggiungi options ath9k nohwcrypt=1 al file vuoto come indicato
sopra.

Ho seguito la procedura, ma visto che la mancanza di segnale accade raramente, non so se la procedura suggerita è utile.
Cita messaggio
Grazie da:
#5
Si avevo letto quello che avevi scritto che accade con entrambi i sistemi operativi, per questo ti ho lasciato i link nei quali c'è scritto che il driver è supportato dal kernel e si installa senza intervento dell'utente, salvo casi particolari.

Questo suggerisce un possibile problema hardware, molto difficile da verificare.
Ad esempio quando si interrompe la connessione, hai provato a vedere con :
lsusb
se la periferica è ancora presente nella lista.
Oppure con :
lspci -knn (puoi vedere l'hardware complessivo e i driver che usa )
sudo lshw - c network ( vedi solo le periferiche che si collegano a internet )
il driver è presente o deve essere ricaricato ?

Se la risposta è che il sistema la vede e il driver è caricato, può essere verosimilmente un problema di hardware.
Cita messaggio
Grazie da:
#6
(05-10-2015,21:07 )supertuxkart Ha scritto: Si avevo letto quello che avevi scritto che accade con entrambi i sistemi operativi, per questo ti ho lasciato i link nei quali c'è scritto che il driver è supportato dal kernel e si installa senza intervento dell'utente, salvo casi particolari.

Questo suggerisce un possibile problema hardware, molto difficile da verificare.
Ad esempio quando si interrompe la connessione, hai provato a vedere con :
lsusb
se la periferica è ancora presente nella lista.
Oppure con :
lspci -knn (puoi vedere l'hardware complessivo e i driver che usa )
sudo lshw - c network ( vedi solo le periferiche che si collegano a internet )
il driver è presente o deve essere ricaricato ?

Se la risposta è che il sistema la vede e il driver è caricato, può essere verosimilmente un problema di hardware.
Grazie, domani proverò. Intanto volevo chiederti una cosa.
Ho eseguito questa procedura che mi è stata suggerita:

Prova da terminale ad aprire il file ath9.conf dando

Codice: Seleziona tutto
sudo gedit /etc/modprobe.d/ath9k.conf


Nel file aggiungi questa riga

Codice: Seleziona tutto
options ath9k nohwcrypt=1


Salva e riavvia

Il pc si collega e questa è già una buona cosa. Visto che non so se la situazione è migliorata, se volessi tornare indietro, si può?
Cita messaggio
Grazie da:
#7
Certamente puoi tornare indietro, basta che fai esattamente il contrario.
Cancelli la riga aggiunta:
options ath9k nohwcrypt=1
salvi e riavvi.
Cita messaggio
Grazie da: tiltmug


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)