Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu non fa più gli aggiornamenti
#1
Buonasera,
vi spiego il mio problema:

Avevo selezionato sul mio PC (senza aver capito cosa significava....) il flag relativo agli aggiornamenti proposti.
I primi di febbraio, a seguito di un aggiornamento, non ha più funzionato il WIFI.
Leggendo nei vari forum sono riuscito a sistemare il problema scaricando una versione precedente delle librerie che causavano il problema e forzando il downgrade.

Le librerie scaricate sono:
  • libnl-route-3-200_3.2.21-1_amd64.deb
  • libnl-3-200_3.2.21-1_amd64.deb
  • libnl-genl-3-dev_3.2.21-1_amd64.deb
Le ho installate con il comando:
  • sudo dpkg --force-downgrade -i *.deb
E tutto ha ripreso a funzionare, apparentemente bene.

In realtà non venivano fatti gli aggiornamenti.

Anche provando da terminale:

sudo apt-get updade --> OK
sudo apt-get upgrade --> mi dice che ci sono dipendenze non risolte e consiglia di lanciare "sudo apt-get -f install"
sudo apt-get -f install --> Dice che non riesce a correggere le dipendenze

Come risolvo?
non vorrei fare troppi casini perchè il PC lo uso per lavoro e non vorrei reinstallare tutto

grazie
Cita messaggio
Grazie da:
#2
se non posti output del terminale non si può nemmeno provare a capire.

posta tutto l'output di
Codice:
sudo apt-get update
e di 
Codice:
sudo apt-get install -f
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#3
si, eccoli


Codice:
nicola@nicola-asus:~$ sudo apt-get update
[sudo] password for nicola:
Ign http://archive.canonical.com precise InRelease
Trovato http://archive.canonical.com precise Release.gpg                      
Trovato http://archive.canonical.com precise Release                          
Trovato http://archive.canonical.com precise/partner amd64 Packages            
Trovato http://archive.canonical.com precise/partner i386 Packages            
Trovato http://archive.canonical.com precise/partner Translation-en            
Ign http://extras.ubuntu.com precise InRelease                                
Scaricamento di:1 http://extras.ubuntu.com precise Release.gpg [72 B]          
Trovato http://extras.ubuntu.com precise Release                              
Trovato http://extras.ubuntu.com precise/main amd64 Packages                  
Trovato http://extras.ubuntu.com precise/main i386 Packages                    
Ign http://extras.ubuntu.com precise/main Translation-it_IT                    
Ign http://extras.ubuntu.com precise/main Translation-it                      
Ign http://extras.ubuntu.com precise/main Translation-en                    
Ign http://archive.ubuntu.com trusty InRelease                              
Scaricamento di:2 http://archive.ubuntu.com trusty-updates InRelease [65,9 kB]
Scaricamento di:3 http://archive.ubuntu.com trusty-backports InRelease [65,9 kB]
Scaricamento di:4 http://archive.ubuntu.com trusty-security InRelease [65,9 kB]
Trovato http://archive.ubuntu.com trusty Release.gpg                          
Scaricamento di:5 http://archive.ubuntu.com trusty-updates/main Sources [264 kB]
Scaricamento di:6 http://archive.ubuntu.com trusty-updates/restricted Sources [5.352 B]
Scaricamento di:7 http://archive.ubuntu.com trusty-updates/universe Sources [151 kB]
Scaricamento di:8 http://archive.ubuntu.com trusty-updates/multiverse Sources [5.946 B]
Scaricamento di:9 http://archive.ubuntu.com trusty-updates/main amd64 Packages [731 kB]
Scaricamento di:10 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [15,9 kB]
Scaricamento di:11 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [339 kB]
Scaricamento di:12 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [13,2 kB]
Scaricamento di:13 http://archive.ubuntu.com trusty-updates/main i386 Packages [703 kB]
Scaricamento di:14 http://archive.ubuntu.com trusty-updates/restricted i386 Packages [15,6 kB]
Scaricamento di:15 http://archive.ubuntu.com trusty-updates/universe i386 Packages [340 kB]
Scaricamento di:16 http://archive.ubuntu.com trusty-updates/multiverse i386 Packages [13,6 kB]
Trovato http://archive.ubuntu.com trusty-updates/main Translation-en          
Trovato http://archive.ubuntu.com trusty-updates/multiverse Translation-en    
Trovato http://archive.ubuntu.com trusty-updates/restricted Translation-en    
Trovato http://archive.ubuntu.com trusty-updates/universe Translation-en      
Scaricamento di:17 http://archive.ubuntu.com trusty-backports/main Sources [8.696 B]
Scaricamento di:18 http://archive.ubuntu.com trusty-backports/restricted Sources [28 B]
Scaricamento di:19 http://archive.ubuntu.com trusty-backports/universe Sources [34,0 kB]
Scaricamento di:20 http://archive.ubuntu.com trusty-backports/multiverse Sources [1.898 B]
Scaricamento di:21 http://archive.ubuntu.com trusty-backports/main amd64 Packages [9.782 B]
Scaricamento di:22 http://archive.ubuntu.com trusty-backports/restricted amd64 Packages [28 B]
Scaricamento di:23 http://archive.ubuntu.com trusty-backports/universe amd64 Packages [41,0 kB]
Scaricamento di:24 http://archive.ubuntu.com trusty-backports/multiverse amd64 Packages [1.571 B]
Scaricamento di:25 http://archive.ubuntu.com trusty-backports/main i386 Packages [9.797 B]
Scaricamento di:26 http://archive.ubuntu.com trusty-backports/restricted i386 Packages [28 B]
Scaricamento di:27 http://archive.ubuntu.com trusty-backports/universe i386 Packages [41,0 kB]
Scaricamento di:28 http://archive.ubuntu.com trusty-backports/multiverse i386 Packages [1.552 B]
Scaricamento di:29 http://archive.ubuntu.com trusty-backports/main Translation-en [5.843 B]
Scaricamento di:30 http://archive.ubuntu.com trusty-backports/multiverse Translation-en [1.215 B]
Scaricamento di:31 http://archive.ubuntu.com trusty-backports/restricted Translation-en [28 B]
Scaricamento di:32 http://archive.ubuntu.com trusty-backports/universe Translation-en [35,5 kB]
Scaricamento di:33 http://archive.ubuntu.com trusty-security/main Sources [109 kB]
Scaricamento di:34 http://archive.ubuntu.com trusty-security/restricted Sources [4.035 B]
Scaricamento di:35 http://archive.ubuntu.com trusty-security/universe Sources [34,0 kB]
Scaricamento di:36 http://archive.ubuntu.com trusty-security/multiverse Sources [2.750 B]
Scaricamento di:37 http://archive.ubuntu.com trusty-security/main amd64 Packages [444 kB]
Ign http://download.videolan.org  InRelease                                    
Trovato http://download.videolan.org  Release.gpg                              
Scaricamento di:38 http://archive.ubuntu.com trusty-security/restricted amd64 Packages [13,0 kB]
Trovato http://download.videolan.org  Release                                  
Trovato http://download.videolan.org  Sources                                  
Trovato http://download.videolan.org  Packages                                
Scaricamento di:39 http://archive.ubuntu.com trusty-security/universe amd64 Packages [125 kB]
Scaricamento di:40 http://archive.ubuntu.com trusty-security/multiverse amd64 Packages [4.991 B]
Scaricamento di:41 http://archive.ubuntu.com trusty-security/main i386 Packages [417 kB]
Ign http://download.videolan.org  Translation-it_IT                            
Ign http://download.videolan.org  Translation-it                              
Scaricamento di:42 http://archive.ubuntu.com trusty-security/restricted i386 Packages [12,7 kB]
Ign http://download.videolan.org  Translation-en                              
Scaricamento di:43 http://archive.ubuntu.com trusty-security/universe i386 Packages [125 kB]
Scaricamento di:44 http://archive.ubuntu.com trusty-security/multiverse i386 Packages [5.175 B]
Trovato http://archive.ubuntu.com trusty-security/main Translation-en          
Trovato http://archive.ubuntu.com trusty-security/multiverse Translation-en    
Trovato http://archive.ubuntu.com trusty-security/restricted Translation-en    
Trovato http://archive.ubuntu.com trusty-security/universe Translation-en      
Trovato http://archive.ubuntu.com trusty Release                              
Trovato http://archive.ubuntu.com trusty/main Sources                          
Trovato http://archive.ubuntu.com trusty/restricted Sources                    
Trovato http://archive.ubuntu.com trusty/universe Sources                      
Trovato http://archive.ubuntu.com trusty/multiverse Sources                    
Trovato http://archive.ubuntu.com trusty/main amd64 Packages                  
Trovato http://archive.ubuntu.com trusty/restricted amd64 Packages            
Trovato http://archive.ubuntu.com trusty/universe amd64 Packages              
Trovato http://archive.ubuntu.com trusty/multiverse amd64 Packages            
Trovato http://archive.ubuntu.com trusty/main i386 Packages                    
Trovato http://archive.ubuntu.com trusty/restricted i386 Packages              
Trovato http://archive.ubuntu.com trusty/universe i386 Packages                
Trovato http://archive.ubuntu.com trusty/multiverse i386 Packages              
Trovato http://archive.ubuntu.com trusty/main Translation-it                  
Trovato http://archive.ubuntu.com trusty/main Translation-en                  
Trovato http://archive.ubuntu.com trusty/multiverse Translation-it            
Trovato http://archive.ubuntu.com trusty/multiverse Translation-en            
Trovato http://archive.ubuntu.com trusty/restricted Translation-it            
Trovato http://archive.ubuntu.com trusty/restricted Translation-en            
Trovato http://archive.ubuntu.com trusty/universe Translation-it              
Trovato http://archive.ubuntu.com trusty/universe Translation-en              
Ign http://archive.ubuntu.com trusty/main Translation-it_IT                    
Ign http://archive.ubuntu.com trusty/multiverse Translation-it_IT              
Ign http://archive.ubuntu.com trusty/restricted Translation-it_IT              
Ign http://archive.ubuntu.com trusty/universe Translation-it_IT                
Recuperati 4.283 kB in 19s (218 kB/s)                                          
Lettura elenco dei pacchetti... Fatto



Codice:
nicola@nicola-asus:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
libnl-genl-3-200 : Dipende: libnl-3-200 (= 3.2.21-1ubuntu1) ma la versione 3.2.21-1 è installata
libnl-genl-3-dev : Dipende: libnl-genl-3-200 (= 3.2.21-1) ma la versione 3.2.21-1ubuntu1 è installata
E: Dipendenze non trovate. Riprovare usando -f.

Codice:
nicola@nicola-asus:~$ sudo apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... non riuscita.
I seguenti pacchetti hanno dipendenze non soddisfatte:
libnl-genl-3-200 : Dipende: libnl-3-200 (= 3.2.21-1ubuntu1) ma la versione 3.2.21-1 è installata
libnl-genl-3-dev : Dipende: libnl-genl-3-200 (= 3.2.21-1) ma la versione 3.2.21-1ubuntu1 è installata
E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.
E: Impossibile correggere le dipendenze
Cita messaggio
Grazie da:
#4
ma quei pacchetti che vedi nell'output li hai bloccati tu a quella versione?

questi che dicono?
Codice:
apt-cache policy libnl-genl-3-200 libnl-genl-3-dev

Codice:
dpkg --get-selections | grep hold
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#5
Prova a dare una letta a questo:
http://www.istitutomajorana.it/forum/Thr...i-bloccati

Hai provato ad aggiornare da synaptic?
Cita messaggio
Grazie da:
#6
(17-03-2016,08:07 )tuxino Ha scritto: ma quei pacchetti che vedi nell'output li hai bloccati tu a quella versione?

questi che dicono?
Codice:
apt-cache policy libnl-genl-3-200 libnl-genl-3-dev

Codice:
dpkg --get-selections | grep hold


Avevo fatto i downgrade delle librerie libnl ma non credo di averle bloccate a quella versione.

Codice:
nicola@nicola-asus:~$ apt-cache policy libnl-genl-3-200 libnl-genl-3-dev
libnl-genl-3-200:
 Installato: 3.2.21-1ubuntu1
 Candidato:  3.2.21-1ubuntu1
 Tabella versione:
*** 3.2.21-1ubuntu1 0
       100 /var/lib/dpkg/status
    3.2.21-1 0
       500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libnl-genl-3-dev:
 Installato: 3.2.21-1
 Candidato:  3.2.21-1
 Tabella versione:
*** 3.2.21-1 0
       500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
       100 /var/lib/dpkg/status


Codice:
nicola@nicola-asus:~$ dpkg --get-selections | grep hold
nicola@nicola-asus:~$
Cita messaggio
Grazie da:
#7
(17-03-2016,08:13 )Gabrio Ha scritto: Prova a dare una letta a questo:
http://www.istitutomajorana.it/forum/Thr...i-bloccati

Hai provato ad aggiornare da synaptic?

synaptic non l'ho potuto installare.
finchè non risolvo non posso fare nessun aggiornamento / installazione

Anche il software center non funziona
Cita messaggio
Grazie da:
#8
prova a rimuovere i 2 pacchettie a reinstallarli, se si tira dietro i pacchetti giusti
Codice:
sudo apt-get remove libnl-3-200 libnl-genl-3-200
Codice:
sudo apt-get install -f
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#9
(17-03-2016,08:38 )tuxino Ha scritto: prova a rimuovere i 2 pacchettie a reinstallarli, se si tira dietro i pacchetti giusti
Codice:
sudo apt-get remove libnl-3-200 libnl-genl-3-200
Codice:
sudo apt-get install -f

Ho provato ma mi sembra che il remove non funzioni....

Codice:
nicola@nicola-asus:~$ sudo apt-get remove libnl-3-200 libnl-genl-3-200
[sudo] password for nicola:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
crda : Dipende: libnl-3-200 (>= 3.2.7) ma non sta per essere installato
       Dipende: libnl-genl-3-200 (>= 3.2.7) ma non sta per essere installato
iw : Dipende: libnl-3-200 (>= 3.2.3) ma non sta per essere installato
     Dipende: libnl-genl-3-200 (>= 3.2.3) ma non sta per essere installato
libnl-3-dev : Dipende: libnl-3-200 (= 3.2.21-1) ma non sta per essere installato
libnl-genl-3-dev : Dipende: libnl-genl-3-200 (= 3.2.21-1) ma non sta per essere installato
libnl-route-3-200 : Dipende: libnl-3-200 (= 3.2.21-1) ma non sta per essere installato
network-manager : Dipende: libnl-3-200 (>= 3.2.7) ma non sta per essere installato
                  Dipende: libnl-genl-3-200 (>= 3.2.7) ma non sta per essere installato
ntrack-module-libnl-0 : Dipende: libnl-3-200 (>= 3.2.21) ma non sta per essere installato
plainbox-provider-resource-generic : Dipende: libnl-3-200 (>= 3.2.7) ma non sta per essere installato
                                     Dipende: libnl-genl-3-200 (>= 3.2.7) ma non sta per essere installato
wpasupplicant : Dipende: libnl-3-200 (>= 3.2.7) ma non sta per essere installato
                Dipende: libnl-genl-3-200 (>= 3.2.7) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).

anche per l'install -f non è cambiato nulla.

Codice:
nicola@nicola-asus:~$ sudo apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... non riuscita.
I seguenti pacchetti hanno dipendenze non soddisfatte:
libnl-genl-3-200 : Dipende: libnl-3-200 (= 3.2.21-1ubuntu1) ma la versione 3.2.21-1 è installata
libnl-genl-3-dev : Dipende: libnl-genl-3-200 (= 3.2.21-1) ma la versione 3.2.21-1ubuntu1 è installata
E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.
E: Impossibile correggere le dipendenze
Cita messaggio
Grazie da:
#10
mah, adesso ti chiede versioni ancora piu aggiornate dei pacchetti.

fatti un backup dei dati e reinstalla 14.04.4 e questa volta non abilitare piu i proposed
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)