Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Voce default GRUB
#1
Ciao a tutti sono nuovo.
Ho letto la vs. guida al link
http://www.istitutomajorana.it/index.php...&Itemid=33


ma nonostante abbia seguito alla lettera il tutto ed impostato la riga 3 come default (nel mio caso windows compare alla riga 3) e abbia fatto anche l'update con
sudo su
password
update-grub


al reboot di default è sempre la prima riga (ubuntu)

come mai? grazie Smile
Cita messaggio
Grazie da:
#2
Dovresti dare sudo update-grub Tuxse non sbaglio.
Pace e Serenità a tutti voi per un mondo migliore Tongue  Heart
Cita messaggio
Grazie da:
#3
prova a modificare /etc/default/grub che la modifica è permanente, posta l'output di questi
Codice:
cat /boot/grub/grub.cfg | grep -i windows
e
Codice:
cat /etc/default/grub
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#4
Ciao intanto grazie a tutti per le risposte. Se posso chiedervi una cosa di motivare i comandi.Siccome sto imparando da 1 giorno mi piacerebbe capire i comandi che E I RISULTATI!

unecc-ThinkPad-T61p:~$ cat /boot/grub/grub.cfg | grep -i windows
menuentry 'Windows 7 (loader) (su /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-F2CA4084CA4046D7' {


unecc-ThinkPad-T61p:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Cita messaggio
Grazie da:
#5
ho modificato il valore del file che mi hai detto....ma niente


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=3
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Cita messaggio
Grazie da:
#6
dai
Codice:
sudo gedit /etc/default/grub
e al posto di
Codice:
GRUB_DEFAULT=0
metti
Codice:
GRUB_DEFAULT='Windows 7 (loader) (su /dev/sda1)'
fatta la modifica, salva il file e chiudilo e poi dai

Codice:
sudo update-grub
e riavvia
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#7
prova col consiglio di tuxino, così la riga di windows dovrebbe essere quella di default indipendentemente dalla posizione.

col metodo dei numeri invece, ricordati che in informatica 0 (zero) è un numero che viene prima di 1, quindi se la riga da scegliere come default è la terza, grub_default=2; infatti se noti, la prima riga è grub_default=0.

ciao
Scusate il ritardo...  Angel
Grazie a chi dice Grazie  At
Usate l'errore come chiave di ricerca su Google
Cita messaggio
Grazie da:
#8
Allora partendo dal presupposto che il mio era un errore da niubbo perchè avevo inserito
GRUB_DEFAULT=3
piuttosto che
GRUB_DEFAULT=2
Testato e funziona alla fine ho optato per la soluzione elegante di Tuxino inserendo
GRUB_DEFAULT='Windows 7 (loader) (su /dev/sda1)'


Una domanda per capire almeno come funziona il grub.
Il file principale è /etc/default/grub che genera poi /boot/grub/grub.cfg?
Cita messaggio
Grazie da:
#9
il file /boot/grub/grub.cfg non è generato solo da /etc/default/grub ma anche dagli script in /etc/grub.d e se si deve modificare grub conviene farlo direttamente dagli script in questione, altrimenti modificando grub.cfg le modifiche vengono perse ad ogni aggiornamento del kermel o di grub.
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#10
x unecc: tutti noi siamo stati "niubbi", non ti preoccupare e non avere timore a chiedere.
ricordati di mettere risolto nel titolo della discussione, modificando il tuo primo post che l'ha aperta
ciao
Scusate il ritardo...  Angel
Grazie a chi dice Grazie  At
Usate l'errore come chiave di ricerca su Google
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)