SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
account root non funziona
#21
Da tutta questa discussione non ho capito qual'era la password di root impostata durante l'installazione.
Pclos chiede di impostarla prima del primo riavvio (mi pare, a memoria) che comunque avviene anche senza digitarla e solo dopo il primo riavvio chiede di creare un utente.
Quindi una password di root personalizzata è stata creata per forza.

La password 'root' è quella che di solito si imposta per le live ma poi al momento di installare il sistema è molto raccomandabile non usarla in quanto è esattamente quella che un eventuale attacco cercherebbe di sfruttare per prima.
Cita messaggio
Grazie da:
#22
@footstep: ho provato, ma la situazione è peggiorata, ora non mi riconosce neanche la password che inserisco per compiere operazioni di root, tipo synaptic o thunar root
@Zafran: ovviamente la password di root era una personale creata in fase di installazione, non mi sognerei di inserire "root" come password di root
Cita messaggio
Grazie da:
#23
Ultima spiaggia (ma ci deve essere qualche cosa di corrotto nel tuo sistema, dato che quello che ti succede non e' assolutamente normale): togliamo la password di root.  Ti do le istruzioni passo-passo (che devi scrivere ESATTAMENTE come te le passo):

  1. Entra in safe mode. Arrivi ad uno schermo nero con prompt '#' (ora sei root)
  2. cp /etc/shadow /etc/shadow.old
    (abbiamo fatto una copia di backup del file)
  3. vi /etc/shadow
    (editor di testo del file /etc/shadow)
    Ti si apre una schermata con il contenuto del file /etc/shadow. La prima riga (se non e' la prima riga muoviti con le frecce fino a quando non trovi una linea che inzia con root) dovrebbe contenere qualche cosa del tipo
    Codice:
    root:caratteri a capocchia:16875:0:99999:7:::
    dove 'caratteri a capocchia' sono una serie di caratteri casuali corrispondenti alla password di root criptata. La riga e' codificata come una serie di campi separati da due punti. Per togliere la password di root dobiamo rendere vuoto il campo corrispondente. Per farlo ti muovi con le frecce sul primo carattere 'a capocchia' ed inizi a premere il tasto 'x'  (senza le virgolette) della tastiera. Questo comando cancella il carattere a destra del cursore.  Continua a premere 'x' fino a quando arrivi ai due punti successivi. La riga dovrebbe ora essere
    Codice:
    root::16875:0:99999:7:::
    ]
    Per salvare ed uscire premi 'ZZ' (cioe' la lettera Z maiuscola due volte). Dovresti essere ritornato al prompt '#'. Se invece hai fatto errori, per uscire senza salvare premi prima ':' Ti si apre una linea in basso nello schermo con un : Inserisci 'q!' (la lettera q ed il punto esclamativo) ed invio.
  4. reboot

Alla schermata di login grafica prova ad entrare come root, lasciando vuoto il campo password e vediamo cosa succede.  Se riesci ad entrare, apri un terminale e digita passwd  Ti chiedera' di inserire la (nuova) password di root. Puoi controllare dando il comando cat /etc/shadow e vedrai che ora il campo password della riga di root non e' piu' vuoto ma conterra' dei 'caratteri a capocchia'.
Esci da root ed entra come utente e vedi se ti funziona tutto.

Facci sapere.

Nel caso qualche cosa andasse storto, puoi sempre ritornare alla condizione precedente rimettendo a posto il file /etc/shadow che abbiamo modificato. Entra in safe mode e dai il comando
Codice:
mv /etc/shadow.old /etc/shadow

Ciao, Mauro
CPU: Intel 6-Core i7-5820K (Haswell rev.2)
nVidia GeForce GTX 750 (drv 430.40),  16GB DDR4 RAM
‎Intel C610/X99 HD Audio / Intel I210 Gigabit Network
Supermicro C7X99-OCE
KDE Plasma:5.16.4 Frameworks:5.61.0 Apps:19.08.0
X.org:1.20.5 Qt:4.8.7/5.12.4
Kernel 5.2.10-pclos1 (gcc 9.2.0)
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: