Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
audio gracchiante con Xubuntu 16.04 su sony vaio vgn-fs515b
#1
Buongiorno a tutti,
ho installato Xubuntu 16.04 su un Vaio del 2006 e nonostante l'età funziona molto bene, perfino la connessione wifi che su windows dava noie di installazione con xubuntu è partita al primo colpo.

Ho un solo grosso problema che si è manifestato fin dalla prima prova con il dvd live: l'audio va a scatti e gracchia, come se facesse on-off in maniera casuale. Stesso problema con una live mint 18. Nessun problema invece con una live Xubuntu 12.04.

Sono passate ormai parecchie settimane dall'installazione e dopo ore e ore di ricerche su web e numerosi tentativi, l'unico risultato che ho ottenuto è una "riduzione" della frequenza del ticchettio. Si sentono mediamente 3 o 4 colpetti e poi 5 o 10 secondi di silenzio.
Se apro alsamixer (automute enalbled, altrimenti la frequenza del ticchettio aumenta parecchio) vedo che i canali master e headphone cambiano volume da soli a ritmo dei click che si sentono dagli altoparlanti. Contemporaneamente compare la notifica nell'angolo dello schermo che mi mostra il cursore del volume, come se io avessi volontariamente cambiato il volume.
Oltre a cambiare di volume, a volte cambiano anche le impostazioni "mute": i due canali master e headphone vanno in MM e poi si riattivano da soli.

Se apro controllo volume (pavucontrol) e guardo su "uscite" vedo che il menù a tendina passa automaticamente da "linea out (unplugged)" a "cuffie analogiche (unplugged)" e viceversa. Come se io attaccassi o staccassi cavetti audio, ma in realtà io non tocco niente. Che le cuffie siano attaccate o meno al pc, il problema è uguale.

Ho fatto un sacco di prove e leggendo nei forum su web ho trovato diversi casi come il mio che non arrivavano da nessuna parte. Credo che il denominatore comune sia dato da portatile sony con scheda audio realtek, in particolare la ALC260.

Non riesco ad arrendermi all'idea che non ci sia niente da fare, perché l'audio, nei brevi periodi in cui non ci sono i ticchettii, si sente bene. Ci deve essere una soluzione!

L'idea che mi sono fatto è che ci sia qualche "interferenza". Per esempio ho provato a mettere in blacklist il modem e mi pare che questo abbia portato miglioramento ma non ne sono sicuro perché assieme a quel tentativo probabilmente ho fatto anche altro. Ora vorrei provare a disattivare tutto il disattivabile.

Se fosse un pc desktop staccherei tutte le periferiche fino a trovare quella che crea il problema, essendo un portatile e non avendo conoscenze su come disattivare l'hardware senza disconnetterlo fisicamente, non so come fare. Per il momento ho escluso il touchpad da Xubuntu, dato che uso il mouse. Vorrei disattivare un lettore di schede di memoria che è acceso (a giudicare dal led) e ha un formato che non mi serve ma non so come fare. Anche la firewire non mi serve e si potrebbe disattivare, ammesso che sia lei a dare problemi. Stessa cosa per il wifi. Magari una volta individuato il problema si riesce a riattivarlo in modo da non creare problemi ad Alsa. Sempre nell'ipotesi che ci sia qualcosa di "esterno" ad Alsa che dà fastidio.

Non so se è una buona idea.

A saperlo fare la cosa migliore sarebbe "chiedere ad Alsamixer chi è che gli dice di cambiare volume"!

Un amico mi ha anche suggerito di cambiare l'irq della scheda audio ma non si può fare da Bios e non io sono riuscito a trovare in rete il modo per farlo da terminale. Ho letto di irqbalance ma non riesco a scaricarlo, probabilmente sbaglio qualcosa.

Spero che qualche esperto possa aiutarmi a risolvere!

Intanto grazie per l'attenzione.
Paolo
Cita messaggio
Grazie da:
#2
magari partendo dalle cose semplici, in driver aggiuntivi non ti segnala nulla?
oppre avanzare a 16.04.2 > http://wiki.ubuntu-it.org/Rilasci/PointRelease
ovviamente sono tentativi, ma perchè non provarci?
Cita messaggio
Grazie da: paolo6
#3
grazie, ogni suggerimento è gradito!
Come driver aggiuntivo mi compariva solo intel microcode, ho provato ad attivarlo senza risultato. In seguito mi è venuto il dubbio che fosse disabilitato di default in qualche file di configurazione che ho avuto modo di aprire nei vari tentativi, perché mi pare di aver trovato una riga di comando riferita proprio a microcode.

Riguardo l'avanzamento di versione non sapevo fosse disponibile, mi sono limitato a scaricare gli aggiornamenti. Provo e ti faccio sapere. Grazie ancora.

EDIT:

Fatto l'avanzamento a 16.04.02. C'è stato un certo miglioramento: la frequenza del ticchettio si è un po' ridotta, tuttavia il problema permane, i volumi vanno per conto loro, l'audio si disattiva e riattiva ancora in modo casuale. Mi pare che alzando il volume l'instabilità sia maggiore, ma anche tenendolo basso dopo un po' sballa.  Se vado in alsamixer e imposto auto mute disable la frequenza aumenta notevolmente, sembra una raffica di mitragliatrice (succedeva anche prima). Questa influenza dell'auto-mute è un indizio utile a capire l'origine del problema?

Altre idee?
Cita messaggio
Grazie da:
#4
Ho rifatto un tentativo dopo settimane di pausa: ho aperto il file /etc/modprobe.d/blacklist.conf e ho messo in blacklist 3 moduli che non mi servono:

# firewire, storage controller, pcmcia card
blacklist firewire_ohci
blacklist tifm_7xx1
blacklist yenta_cardbus

La novità è che al primo riavvio il rumore è diminuito. I click si sentono meno frequentemente, magari una o due volte al minuto, mentre prima era continuo e faceva diventare matti.
Al secondo riavvio stranamente i click sembrano aumentati, ma non al livello di prima... mah!

Visto il parziale miglioramento e visto che con il cd live di 12.04 il ticchettio non c'era, vorrei provare a disattivare altri moduli che potrebbero interferire, ma come faccio a capire quali posso disattivare senza creare problemi o addirittura bloccare il sistema?
Cita messaggio
Grazie da:
#5
hai provato ad eliminare la cartella pulse in ~/.config/pulse e riavviare ?
Cita messaggio
Grazie da:
#6
Grazie per il suggerimento, ho riprovato ma la situazione purtroppo non è migliorata.
Cita messaggio
Grazie da:
#7
Ciao
Pavucontrol è installato?
prova a verificare con lui se c è qualcosa che non va.

ps ho visto adesso che hai gia controllato però posta una schermata di pavucontrol in particolare la scheda configurazione.
dovrebbe essere impostato duplex stereo analogico.
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....
Cita messaggio
Grazie da:
#8
Allego la schermata, aggiungo anche quella in cui si vede il continuo passaggio tra plugged in e unplugged, analogo a quello che si vede in alsamixer.
Grazie

EDIT
Ho provato a modificare le impostazioni del file /etc/modprobe.d/alsa-base.conf provando varie opzioni nel comando:

options snd-hda-intel model=sony_laptop

"sony_laptop" me lo sono inventato io ma stranamente, insieme ad "acer" è una delle impostazioni che riduce maggiormente il problema.

Mi colpisce il fatto che il problema si accentua terribilmente se disabilito l'opzione "auto mute" in Alsamixer, ma non sono in grado di trarne le conseguenze.


Allegati Anteprime
           
Cita messaggio
Grazie da:
#9
A suo tempo sulla Ubuntu 12.04 avevo lo stesso problema. Avevo risolto editando il file
/etc/pulse/default.pa
Aggiungendo "tsched=0" alla linea "module-udev-detect" ottenendo:
Codice:
load-module module-udev-detect tsched=0
Non so se la procedura funzioni anche su xubuntu 16.04, ma puoi provare. Tongue
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#10
Grazie, avevo già provato, ho verificato e la situazione del file in questione è la seguente:

Codice:
### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif


se può essere utile a qualcuno che ne capisce, qui c'è l'attuale configurazione:
http://www.alsa-project.org/db/?f=2f69ec...0dac5a5a7f
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)