Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
avvio script bash da Debian 9
#1
Ciao.
Ho creato una configurazione di iptables in formato .sh, affinchè potessi configurare l'applicazione in automatico all'avvio del sistema.
Con Debian 8 non ho avuto disagi, affinchè non abbia installato Debian 9.
Utilizzavo la directory rc.local in Debian 8 e copiavo lo script, dando i permessi chmod 775: in Debian 9, non mi è possibile avviare automaticamente lo script.sh

Ho creato lo script quando segue questa guida, ma l'avvio non sussiste: facendo iptables -L, la configurazione non è presente.
Ho provato anche a collocare lo script in "programmi di avvio" e in nella directory home (non influente), ma il sistema si blocca.

http://www.istitutomajorana.it/forum2/Th...me-crearli


Debbo scaricare pacchetti perchè il sistema avvii uno script bash ?

Lo script bash inizia con  "#!/bin/bash" e termina con "exit"
Cita messaggio
Grazie da:
#2
Hai provato a lanciare lo script come root? funziona o hai problemi?
metterlo nelle applicazioni di avvio di un utente, credo non funzioni per il fatto che i comandi contenuti nel medesimo possono essere eseguiti solo da root e non da un utente normale, da qui il blocco.
Controlla anche che il file /etc/rc.local abbia i permessi di esecuzione.

Edit: prova anche a modificare lo script mettendo al posto di "#! /bin/bash" "#! /bin/sh" (se controlli nel file rc.local è questa la shell di default)
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#3
Ci sono riuscito e spiego come ripristinare rc.local in debian Strech.
rc.local è una directory non di default ed è possibile ripristinarla facendo così:


nano /etc/rc.local

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0

Salvare il documento e successivamente dare i permessi di esecuzione della directory:

chmod +x /etc/rc.local
systemctl start rc-local
systemctl status rc-local


Ho incollato la soluzione e vi riporto il link in descrizione: https://blog.smsoft.it/2017/10/03/debian...-rc-local/
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)