SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 2 voto(i) - 3 media
  • 1
  • 2
  • 3
  • 4
  • 5
debian-ubuntu-abilitare qgis alla lettura del formato ecw
#11
ho visto il e ci sto "lavorando" .... purtroppo ho poco tempo a disposizione, comunque ti farò sapere
da un primo sguardo pare che la procedura sia sempre la stessa, l'autore ha compilato gdal per far riconoscere
i file ecw e usa gdal 1.11.
a presto At
Cita messaggio
Grazie da:
#12
Luciano si usa gdal 1.11 e ecw SDK 5.3 comunque si installa in modo semplice e facile senza compilare niente e non è poco per chi vuole usare ecw in qgis buona giornata
Cita messaggio
Grazie da:
#13
ho visto lo script è confermo che si tratta della ricompilazione di gdal 1.11
e bisogna installarlo prima di installare qgis, con debian jessie e qgis 2.18 ha funzionato
mentre con linux mint rosa (17) per ora pare di no, probabilmente per il fatto che nei repo c'è gdal 2.0
mentre su jessie c'è ancora 1.10
Cita messaggio
Grazie da:
#14
confermo non funziona nemmeno su ubuntu 16.10 con gdal 2.1
Cita messaggio
Grazie da:
#15
quando procuro un po di tempo provo a compilare gdal 2.1 con il mio metodo At
Cita messaggio
Grazie da:
#16
con ubuntu mate 16.10 gdal 2.1 e qgis 2.18.4 con ecw libecwj2-3.3 funziona bisogna compilarlo
Cita messaggio
Grazie da:
#17
Riprendo la discussione per chiedere se ci sono aggiornamenti per le nuove distribuzioni che usano il gdal 2.x
Anche le nuove versioni di QGis (tipo la 2.18) funzionano, a patto di usare il Gdal 1
Il Punto è .........
sono un Apprendista stregone
Cita messaggio
Grazie da:
#18
ciao subuntu
purtroppo per quanto mi riguarda ho poco tempo a disposizione e per quanto riguarda
qgis è da un po che non lo uso.... e anche come distro linux sono "fermo" a debian jessie
in quanto ho problemi con le schede grafiche.....
quindi confermo che con jessie e qgis 2.18 funziona, nelle nuove non so Idea
Cita messaggio
Grazie da:
#19
Alla fine, dopo innumerevoli tentativi, sono riuscito a venire a capo del problema.
Rispetto alla versione precedente, il gdal 2.x richiede, per poter essere adeguatamente compilato, alcuni pacchetti python.dev.
Ho fatto le prove sia su Debian 9 che su Mint 19, entrambe a 32 bit(con 2 versioni diverse di gdal).
Questa la procedura adottata:
- installare i pacchetti: checkinstall, g++, python-all-dev necessari per la compilazione;
- installare QGis (che si porta appresso anche gdal) e verificare la versione di gdal
- dalla pagina http://trac.osgeo.org/gdal/wiki/DownloadSource scaricare lo zip della propria versione gdal
Comandi da terminale:
wget http://mirror.ovh.net/gentoo-distfiles/d...-09-06.zip
unzip libecwj2-3.3-2006-09-06.zip
wget http://trac.osgeo.org/gdal/raw-attachmen...ixes.patch
patch -p0 < libecwj2-3.3-msvc90-fixes.patch
wget http://osgeo-org.1560.x6.nabble.com/atta...rfix.patch
wget http://trac.osgeo.org/gdal/raw-attachmen...inux.patch

cd libecwj2-3.3/
patch -p0 < ../libecwj2-3.3-NCSPhysicalMemorySize-Linux.patch
patch -p1 < ../libecwj2-3.3-wcharfix.patch
./configure
make -j2
sudo make install
cd ..
unzip gdalxxxx.zip
cd gdalxxxx
./configure --with-ecw=/usr/local --with-python
make -j2
sudo make install
export LD_LIBRARY_PATH=/usr/local/lib
sudo ln -s /usr/lib/libproj.so.0 /usr/lib/libproj.so

a questo punto la compilazione è terminata.
Fare una verifica sempre da terminale
gdalinfo --formats | grep -i ecw

il risultato dovrebbe essere:
ECW (rw): ERDAS Compressed Wavelets (SDK 3.x)
JP2ECW (rw+v): ERDAS JPEG2000 (SDK 3.x)

Ora provare ad aprire Qgis e verificare che tutto funzioni.
In caso di risposta negativa non resta che il "metodo Luciano", brutale ma risolutivo.
Aprire il gestore file su
usr/local/lib  
copiare tutti i file escluse le cartelle (da libecwj2.a  a libNCUtil.so.0.0.0)
incollare in /usr/lib
sovrascrivendo i vecchi file.
Per informazione, ho dovuto usare questa procedura in entrambe le prove sia su debian che su mint
Il Punto è .........
sono un Apprendista stregone
Cita messaggio
Grazie da:
#20
dopo tanto tempo ho ripreso ad occuparmi di qgis e per ora ho provato
la procedura su fedora29 e qgis 3.4 (gdal 2.3.2) ed ha funzionato,
nei prossimi giorni ho intenzione di provarlo su debian testing e su ubuntu 18.10.
Tongue
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: