Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
installare scheda video nvidia su debian jessy
#1
Ciao a tutti, potreste aiutarmi a installare la scheda video su debian?
Ho una gs 8400 512 mb
Ho fatto piccoli passi avanti, ma credo che abbia creato problemi irreparabili; adesso si presenta schermo nero all'infinito impostando nomodeset.
Ho capito il problema, mancavano i reposity non-free: 
http://guide.debianizzati.org/index.php/...o_utilizzo
Una volta configurato, ho avviato questa guida e ho iniziato ad installare i pacchetti necessari ( metodo 1) :


http://guide.debianizzati.org/index.php/...ari_Nvidia
I driver indicati dal sistema sono i legacy 304 e ho scaricato da internet il pacchetto legacy.
Durante l'installazione il sistema, con schermata blu, mi ha detto di abilitare i xconf; ho provato e non ci sono riuscito.
Avvio il processo  # apt-get instale nomepacchetto e non viene installato nulla.
Ho ritentato a procedere nuovamente, ma niente.
Riavvio il pc, ma non parte.
Riavvio nuovamente e imposto nomodeset, ma adesso il pc non parte nemmeno in modalità nomodeset; cosa posso fare?
Devo formattare tutto?
Se si, qual'è stato il mio errore?
Il metodo 3, faceva una installazione tutto in automatico?
Tutto è filato liscio fino a questo processo:
# apt-get install nvidia-glx nvidia-settings linux-headers-`uname -r`
Cita messaggio
Grazie da:
#2
Ma perché scusa gli open nouveau non andavano bene? Cioè, Debian è totalmente open, Debian DEVE essere solo free-software, poi ci sono innumerevoli motivi per scegliere/usare/preferire/volere/ecc.ecc. i vari ubuntu/mint/manjaro/fedora/ecc.ecc.
Poi perché non usi aptitude che risolve pure le dipendenze? mah, io avrei dato aptitude update e poi aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-legacy-xxxx-dkms
Comunque io adesso non so assolutamente com'è la situazione sul tuo hardware, il mio consiglio è di reinstallare tutto e poi di non seguire quelle guide che sono fatte male.
Cita messaggio
Grazie da:
#3
Penso anch'io che sia meglio reinstallare.
Come notizia posso dire che i drivers proprietari mi creavano dei problemi, mentre quelli di sistema, i noveau, non me ne creano. Ogni sistema è diverso e bisogna valutare caso per caso, ma per regola "il Meglio è nemico del Bene". Ovvero: non installare roba sostanzialmente estranea quando tutto funziona.
Freedom isn't free-La libertà non è gratuita.
Per cercare su questo forum: site:istitutomajorana.it/forum2/ [termini della ricerca]
oppure http://www.istitutomajorana.it/informati...lo-forum-2
Cita messaggio
Grazie da:
#4
(09-12-2015,23:23 )Debianity Ha scritto: Ma perché scusa gli open nouveau non andavano bene? Cioè, Debian è totalmente open, Debian DEVE essere solo free-software, poi ci sono innumerevoli motivi per scegliere/usare/preferire/volere/ecc.ecc. i vari ubuntu/mint/manjaro/fedora/ecc.ecc.
Poi perché non usi aptitude che risolve pure le dipendenze? mah, io avrei dato aptitude update e poi aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-legacy-xxxx-dkms
Comunque io adesso non so assolutamente com'è la situazione sul tuo hardware, il mio consiglio è di reinstallare tutto e poi di non seguire quelle guide che sono fatte male.

no purtroppo, gli open non funzionavano, tutto andava a scatti.
Cita messaggio
Grazie da:
#5
Strano, i nouveau prima davano problemi, ma adesso su Jessie vanno meglio dei proprietari.
La prossima volta segui questa guida che è la migliore https://wiki.debian.org/it/NvidiaGraphicsDrivers
Cita messaggio
Grazie da:
#6
(10-12-2015,17:13 )Debianity Ha scritto: Strano, i nouveau prima davano problemi, ma adesso su Jessie vanno meglio dei proprietari.
La prossima volta segui questa guida che è la migliore https://wiki.debian.org/it/NvidiaGraphicsDrivers

Ciao, sono riuscito a sbloccare i driver installati, erano i 340.96.
Per sbloccare il sistema sono entrato in root premendo il tasto ctrl+alt+f1 all'avvio dello schermo nero  e ho digitato apt-get remove nvidia*.
Ho riavviato il pc e ho impostato il comando nomodeset e questa volta debian parte Smile
Adesso riprovo a installare i driver 304.
Cita messaggio
Grazie da:
#7
Mi sono dovuto assentare.
Adesso devi fare attenzione, e come ti dicevo e ti ripeto di usare aptitude, ma forse a quest'ora avrai già risolto.
Cita messaggio
Grazie da:
#8
(10-12-2015,22:54 )Debianity Ha scritto: Mi sono dovuto assentare.
Adesso devi fare attenzione, e come ti dicevo e ti ripeto di usare aptitude, ma forse a quest'ora avrai già risolto.

Ciao, al momento non ho ancora provato; ti saprò dire.
Si è bloccato tutto, non riesco a risbloccarlo; passerò ad un altra distro.
Ho provato ad aggiornare il kernel 3.0 da quello di default 2.0, ma la situazione questa volta pare irreparabile.

Ciao e grazie per i suggerimenti
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)