Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
lettore smart card Digicom aiuto
#1
Ho acquistato il lettore digicom da usare con la carta crs mi sono prima informato e sembra sia compatibile con Linux, il gioco sembrava semplice, da istruzioni introdurre il cd ed estrarre il driver EZUSB_Linux_x86_v1.4.9.tar.gz, detto fatto estratto in Home collego il lettore non funziona  Undecided non so che fare per ora lo buttato in un cassetto, mi spiacerebbe acquistarne un'altro se poi non va..


http://www.digicom.it/digisit/driver_lin...CardReader


Allegati
.gz   EZUSB_Linux_x86_v1.4.9.tar.gz (Dimensione: 33,24 KB / Download: 5)
Cita messaggio
Grazie da:
#2
Per la verità non basta estrarre il tar.gz.
Poi devi entrare nella cartella del driver ed installarlo.

Ponendo che tu abbia estratto nella tua home, in un terminale:
Codice:
$ cd ~/EZUSB_Linux_x86_v1.4.9/driver_ezusb_v1.4.9/
$ chmod 777 check_env
$ chmod 777 install
$ ./check_env
$ sudo ./install
Riavvia il sistema (i comandi chmod servono ad assicurare che siano settati i permessi, non sono strettamente necessari).
Collega il lettore (se non già collegato), inserisci la card (solitamente la luce blinkante diventa fissa, oppure il led cambia colore) ...
[venapolemica] Se hanno fatto un cd apposta, potevano sprecarsi a fare uno scriptino che faceva tutto in automatico. [/venapolemica]

Se non hai già provveduto, sono previamente da installare pcsclite ed il pacchetto del CRS
Codice:
$ sudo apt-get install pcscd libacsccid1 libbit4spki
(l'ultimo dovrebbe essere suggerito dal sito CRS)
e configurare firefox, caricando in Preferenze/Avanzate/Certificati/Dispositivi di sicurezza/Carica il modulo corretto:
Nome modulo=CRS PKCS#11 (o quello che vuoi tu)
Nome file modulo=/usr/lib/libbit4spki.so (o altro indicato dal sito CRS)
Assicurati di riavviare firefox (dopo averne chiusa ogni finestra) prima dell'uso della card.

Bye,
Token
Cita messaggio
Grazie da:
#3
Mi intrometto in ritardo su questa discussione, che ho trovato solo stasera...! Ho anch'io il lettore di smart card della Digicom. Sono riuscito a installarlo correttamente, faccio partire firefox, il marchingegno lampeggia rosso e poi rimane fisso. Per verificare il funzionamento vado nel sito http://www.crs.regione.lombardia.it, faccio partire la verifica dell'installazione, mi chiede il pin, mi fa vedere il mio certificato, dopo la conferma pero' continua a lampeggiare la luce rossa e alla fine viene fuori la schermata seguente.    
Poiche' la discussione non e' proseguita, presumo che abbiate risolto. Potete aiutare anche me?
Grazie.

Falco132
Cita messaggio
Grazie da:
#4
Noto che usi Iceweasel per la navigazione Internet, forse è questo il problema e non solo. Io possiedo un lettore crs (il modello è bit4 ID di Regione Lombardia) e l'unico modo per farlo funzionare è stato quello appena proposto da Token, ovviamente con i comandi di installazione e settaggio adattati al mio modello. Non vorrei sparare una fesseria, ma mi risulta che finora solo Firefox sia predisposto per produrre certificati che poi vengono correttamente riconosciuti. L'ultima versione, la mia installata su Mint17.1, per l'accesso al sito INPS funziona perfettamente.
Cita messaggio
Grazie da:
#5
Quella e' una delle tante schermate :-((
Ho provato anche con firefox 37 e il risultato e' lo stesso. Tra l'altro, nel cd d'installazione del lettore Digicom c'e' un bel programmino che verifica la corretta installazione e riconosce la CRS senza problemi. Per curiosita' ho inserito anche una carta di credito e un bancomat e riconosce senza problemi anche quelli. Percio' sarei abbastanza sicuro della corretta installazione del lettore. Pero' quando uso CRS Manager, il programma che permette di firmare e criptare documenti e anche di cambiare il pin, fa lo stesso problema. Lampeggia infinite volte e poi mi da un errore generico. Mentre, stranamente mi permette di cambiare il pin e una volta anche di ripristinarlo con il puk perche' lo avevo inchiodato...!!! Misteri dell'informatica.
Ciao.
Falco132
Cita messaggio
Grazie da:
#6
Per firmare i documenti prova Dike.

Bye,
Token
Cita messaggio
Grazie da:
#7
Stasera, continuando a girare su internet, ho trovato da qualche parte che bisogna aggiornare le librerie, dopo averne installate di nuove, con il comando:

>sudo ldconfig

e, guarda un po' mi e' venuto fuori questo errore:

ldconfig: /usr/lib/libbit4spki.so_pin.py non è un file ELF - i byte magic iniziali sono sbagliati.
ldconfig: /usr/lib/libbit4xpki.so.conf non è un file ELF - i byte magic iniziali sono sbagliati.

che riguarda proprio la libreria crittografica.
Penso sia un errore di installazione o di versione non compatibile con il mio sistema.
Qualcuno sa qualcosa a proposito di questo avviso?
Falco132
Cita messaggio
Grazie da:
#8
L'avviso "non è un file ELF - i byte magic iniziali sono sbagliati" è abbastanza esplicativo.
Dice che quel codice non è un Executable Linkable Format, ossia un binario con insieme di dati inerenti la rilocabilità del codice in memoria (tipico delle librerie).

Don't worry, quello non è un problema.

Bye,
Token
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)