Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
pclinuxos non si avvia piu
#1
ciao gente oggi ho questo strana anomalia
ho avviato il portatile dove ho installato pclinux-debian-archlinux
solo che al boot no leggo piu pcliux
su gparted ho la partizione
come ripristino???
o faccio prima ad reinstallare????
questa è la partizione
sda3 cè pclinux o ci dovrebbe stare


Allegati Anteprime
   
Cita messaggio
Grazie da:
#2
Codice:
spiry@debian:~$ sudo fdisk -l
[sudo] password di spiry:
Disk /dev/sda: 186,3 GiB, 200049647616 bytes, 390721968 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000bb373

Dispositivo Avvio     Start      Fine   Settori  Size Id Tipo
/dev/sda1              2048 135325695 135323648 64,5G 83 Linux
/dev/sda2         352923648 390721535  37797888   18G 82 Linux swap / Solaris
/dev/sda3   *     135325696 279810047 144484352 68,9G 83 Linux
/dev/sda4         279810048 352923647  73113600 34,9G 83 Linux

Partition table entries are not in disk order.


spiry@debian:~$ sudo mount /dev/sda3 /mnt
spiry@debian:~$ sudo grub-install –root-directory=/mnt /dev/sda
grub-install: errore: Più di un device d'installazione?.
spiry@debian:~$ sudo grub-install –root-directory=/mnt /dev/sda3
grub-install: errore: Più di un device d'installazione?.
spiry@debian:~$
ho dato questi comandi ma nulla
Cita messaggio
Grazie da:
#3
pclinux-debia-arch, uno solo gestirà l'avvio. vai su quello che lo gestisce ed aggiorna il grub.
Cita messaggio
Grazie da:
#4
Dei 3 sistemi operativi installati quale è quello che gestisce il grub di avvio?
hai provato da quel SO a dare un
Codice:
sudo update-grub
o nel caso fosse debian come root:
Codice:
update-grub
e controllare se pclinuxos riappare nell'elenco di avvio?
A volte , causa aggiornamenti non sempre il grub viene aggiornato in maniera completa. A me capita con manjaro. Quando installa un nuovo kernel durante un aggiornamento, poi nel suo grub , che uso per avviare i vari sitemi, trovo solo le voci che riguardano i kernel di manjaro. Dando poi un "sudo update-grub" ho di nuovo l'elenco completo.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#5
scusate il ritardo
allora il grub lo gestiva pcliuxos
quando ho aggiornato debian da stabile a testing ho avuto il problema
ora sto con debian xche lo sta gestendo lui il grub
Codice:
spiry@debian:~$ sudo update-grub
[sudo] password di spiry:
Generazione file di configurazione GRUB...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Trovata immagine linux: /boot/vmlinuz-4.16.0-1-amd64
Trovata immagine initrd: /boot/initrd.img-4.16.0-1-amd64
Trovata immagine linux: /boot/vmlinuz-4.9.0-6-amd64
Trovata immagine initrd: /boot/initrd.img-4.9.0-6-amd64
Trovato PCLinuxOS su /dev/sda3
Trovato Arch Linux su /dev/sda4
fatto
spiry@debian:~$ su
Cita messaggio
Grazie da:
#6
cmq dopo i comandi non è cambiato nulla nonostante sia letto come sistema


Allegati Anteprime
   
Cita messaggio
Grazie da:
#7
Prova con Boot Repair, a volte risolve.
Non fornisco supporto per XP, lasciatelo andare.......Ha fatto il suo lavoro Confused
Cita messaggio
Grazie da:
#8
proverei ad installare/usare il grub di arch. Se ancora non va segui quanto detto da rage75.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#9
supergrubdisk o meglio ancora rescatux aiutano sicuramente la soluzione.
alternativa a questi è avviare una live di pclinux e da terminale:
Codice:
su
mount /dev/sda3 /mnt
for i in /dev /dev/pts /proc /sys; do mount -B $i /mnt$i; done
cp /etc/resolv.conf /mnt/etc/
chroot /mnt
apt-get update
apt-get install --reinstall grub2
update-grub
exit
for i in /sys /proc /dev/pts /dev; do umount /mnt$i; done
umount /mnt

fonte
Cita messaggio
Grazie da:
#10
ciao dxgiusti
ma ho provato con pc resure ma nulla di fatto
alla fine ho dovuto formattare xche anche con archlinux non ne uscivo
grazie cmq
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)