Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
problema: dual boot Linux Mint 17.2 e Windows 7
#1
Buongiorno,amici del forum
ho sistemato un vecchio pc assemblato di un mio amico, con CPU Pentium 4 3.4 ghz, 2 gb di ram, hard disk 160 gb.

Sull'hard disk meccanico da 160 gb è installata una versione (sicuramente non originale di windows 7 ultimate)
Ho acquistato un hard disk ssd da 128 gb su cui ho installato Linux Mint 17.2 Mate Plus Remix 32 bit del Prof. Cantaro.

Mint va bene, nonostante il processore sia un pò scarso.

Il problema è che all'avvio non compare il grub che mi dovrebbe far scegliere se partire con Linux o con windows.

Ho provato ad aggiornare il Grub, ma niente da fare, all'avvio parte direttamente Linux Mint .

Come posso fare per avere entrambi i sistemi in dual boot?

Grazie, Francesco
Cita messaggio
Grazie da:
#2
in mint, nel terminale:
sudo update-grub
invio, pswd, invio.
Cita messaggio
Grazie da: Frankie7 , Frankie7
#3
Grazie, dxgiusti, ho fatto come tu mi hai consigliato, la risposta del terminale è stata questa:

marzio@nino ~ $ sudo update-grub
[sudo] password for marzio:
Generating grub configuration file ...
Found background image: splash-image.png
Found linux image: /boot/vmlinuz-3.16.0-38-generic
Found initrd image: /boot/initrd.img-3.16.0-38-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
No volume groups found
Trovato Windows 7 (loader) su /dev/sda1
Trovato Windows 7 (loader) su /dev/sda2
fatto
marzio@nino ~

Al riavvio, però, parte direttamente Linux Mint, non appare il grub per sciegliere quale sistema operativo far partire

Cosa faccio?
Cita messaggio
Grazie da:
#4
praticamente è come se lui non vedesse la pagina del grub, potrebbe essere molte cose. proviamo la prima, avvia il computer e subito dopo le prime righe che manda il bios, premi in continuazione il tasto shift. vediamo se li appare. sto cercando di capire s è un problema di tempo oppure di risoluzione schermo.
Cita messaggio
Grazie da: Frankie7
#5
Edita il menu GRUB e controlla la voce  #GRUB_TIMEOUT=0  modifica togliendo il cancelletto in questo modo GRUB_TIMEOUT=15

Huh
Cita messaggio
Grazie da: Frankie7
#6
strana la cosa, visto che lo elenca e comunque con due sistemi dovresti vedere grub di default, questo che dice?

Codice:
cat /etc/default/grub
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: Frankie7 , Frankie7
#7
mi viene in mente una cosa, però, tu grub l'hai installato sul disco dove hai messo mint? non è che ora è quel disco che è sulla prima porta sata ( e che risulta come /dev/sda)? che è impostato dal bios come primo dispositivo?e quello meccanico è sulla seconda porta sata della scheda madre? posta anche
Codice:
sudo fdisk -l
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: Frankie7
#8
correte tutti ma potrebbe essere anche un problema di risoluzione dello schermo. direi di lasciarlo provare prima manualmente se appare, poi eventualmente dare un tempo maggiore oppure se non appare nemmeno manualmente cambiare la risoluzione.
Cita messaggio
Grazie da:
#9
Se faccio partire il pc e all'avvio premo il tasto SHIFT, come suggerisce dxgiusti, compare miracolosamente grub e posso avviare anche windows.
Senza il tasto Shift, invece, si avvia direttamente Mint.
Codice:
[GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="vga=789"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

GRUB_GFXPAYLOAD_LINUX="auto"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
marzio@n

Codice:
marzio@nino ~ $ sudo fdisk -l
[sudo] password for marzio:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 testine, 63 settori/tracce, 19457 cilindri, totale 312581808 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x2eea2ee9

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1            2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2   *      206848   312578047   156185600    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 128.0 GB, 128035676160 bytes
255 testine, 63 settori/tracce, 15566 cilindri, totale 250069680 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x000c5af0

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048   245762047   122880000   83  Linux
/dev/sdb2       245762048   250068991     2153472   82  Linux swap / Solaris
marzio@nino ~ $

Come dice dxgiusti, avrei un problema di risoluzione dello schermo, in quanto con Mint non riesco quasi a leggere la barra laterale

   
Cita messaggio
Grazie da:
#10
comunque l'output di /etc/default/grub o non ce' tutto quindi ridai il comando e ripostalo completo, oppure se l'output è tutto quello, allora hai il file con dei problemi. ciao aspetta dxgiusti
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)