Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
riconoscimento monitor
#1
At  Buongiorno a tutti, dopo aver sostituito il mio vecchio monitor con un più performante "Dell U2211H" da 21,5" il mio sistema Ubuntu 16/04 lts non riconosce la periferica e rimane ancorato al "unknown display" con risoluzione massima a 1360x768.
Ho provato a scaricare i driver da Dell, ma non sono riuscito ad installarli (driver per linux).
Chiedo aiuto a chi sa!  Undecided
Grazie Blush
Cita messaggio
Grazie da:
#2
Quale scheda video è installata?? posta il risultato del comando:
Codice:
cat etc/X11/xorg.conf
Cita messaggio
Grazie da:
#3
il comando risponde inesistente.
la mia scheda video è una Nvidia GT218 (Ge force G210). stringa recuperata dai driver aggiuntivi della cartella softhware e aggiornamenti. Il sistema usa driver Nvidia.
Cita messaggio
Grazie da:
#4
Per esser certi dei driver in uso, posta
Codice:
sudo lshw -c video

Quando si installano i driver proprietari nvidia è consigliabile, da terminale, dare il comando
Codice:
sudo nvidia-xconfig
che installa l'applicazione della nvidia per la gestione della grafica (e del monitor) e ti scrive uno xorg.conf ad hoc. Se non lo hai già fatto, fallo.
Cita messaggio
Grazie da: Blackstar
#5
... dopo aver postato il primo comando mi viene risposto che in effetti sto usando:
description: VGA compatible controller
product: GT218 [GeForce G210]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:02:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:25 memory:fd000000-fdffffff memory:d0000000-dfffffff memory:ce000000-cfffffff ioport:ec00(size=128) memory:fea80000-feafffff

poi ho postato il comando: sudo nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'

non sono sicuro di essere capace di aggiungere la directory `xorg-server.pc', posso avere un'amorevole indicazione passo/passo?
Mi scuso per la pochezza tecnica...
Cita messaggio
Grazie da:
#6
I driver sono gli nvidia.
Il secondo listato ti dice (alla fine - le righe precedenti puoi tranquillamente ignorarle-) che ti ha scritto il nuovo file /etc/X11/xorg.conf - ora puoi postarlo come ti ha detto roberto1155.

Hai provato a guardare in Impostazioni->Monitor se è cambiato qualcosa nelle risoluzioni disponibili?
Cita messaggio
Grazie da:
#7
intanto grazie a tutti coloro che hanno risposto, poi mi scuso per il ritardo;
Sono riuscito ad aggiornare i driver di nvidia alla ultima versione disponibile; ripostando il comando di roberto1155 come mi ha suggerito andrea111, la risposta rimane inesistente e nelle impostazioni -> monitor rimane "unknown display"...
Ho tentato anche con l'utilizzo dei driver proposti dal sistema dopo un get upgrade ed un get update, ma ovviamente ho ottenuto un "built in" monitor con risoluzione max 800x600 (dunque sono tornato ai driver di nvidia).
Cita messaggio
Grazie da:
#8
Nel tuo primo intervento parlavi di driver di linux per quel monitor (cosa strana) - mi posti il collegamento da dove li hai scaricati che gli dò un'occhiata? (potrebbe essere un monitor un po' particolare).
Posta anche
Codice:
ls /etc/X11

E allega pure il file /var/log/Xorg.0.log (lo devi allegare - non postare - usa la sezione "Allegati" che vedi appena sotto la finestra dove scrivi l'intervento).
Cita messaggio
Grazie da:
#9
Posta il risultato del comando:
Codice:
cat etc/X11/xorg.conf
e
Codice:
dkms status
Cita messaggio
Grazie da:
#10
potresti installare il pacchetto nvidia-settings, un tool grafico per la configurazione dei driver nvidia, monitor, etc. se lo lanci con i privilegi di amministratore puoi poi salvare la configurazione in /etc/X11/xorg.conf.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)