Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
xorg.conf vuoto e output d'errore
#1
Ciao ragazzi,
sto seguendo questa procedura per configurare il file xorg.conf in modo da avere la risoluzione giusta per il mio monitor.

Giunti al momento di aprire con gedit il file per editarlo, mi apre il file completamente vuoto e mi dà questo output:
Codice:
** (gedit:2388): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-VA7MaR5s42: Connessione rifiutata

(gedit:2388): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

Non capisco: perché il file è vuoto? Io l'ho fatto configurare, come da procedura, col comando sudo X -configure.
Quale può essere il problema?


Per dovizia riepilogo che tra le anomalie riscontrate c'è un messaggio di errore "xrandr: Failed to get size of gamma for output default" ogni volta che do il comando xrandr e altri output anomali quando si richiedono al sistema informazioni o si ordinano operazioni riguardanti le impostazioni grafiche; che sto usando bumblebee, senza l'ausilio (magico e inspiegabile) del quale, i driver nvidia mi portano ad un crash d'avvio con schermata nera. Insomma è un casino, ma già partire dalle piccole cose, tipo sapere perché il file xorg.conf mi rimane tabula rasa, sarebbe un grosso passo avanti.
Cita messaggio
Grazie da:
#2
http://wiki.ubuntu-it.org/Hardware/Video/Xorg
qui le info.
Cita messaggio
Grazie da:
#3
(29-01-2015,14:12 )dxgiusti Ha scritto: http://wiki.ubuntu-it.org/Hardware/Video/Xorg
qui le info.

Leggendola, posso constatare che ho fatto gli stessi passaggi:

sudo X -configure
sudo cp .........

Il problema è che il file è vuoto. Non dovrebbe essere vuoto. E se anche ci fosse la possibilità di crearlo manualmente, sarebbe un casino inserire io tutti i dati, non sono così ferrato.
Cita messaggio
Grazie da:
#4
segui questi passaggi ( ubuntu 14.04 ), apri la console di comando:
alt+ctrl+F2
login, pswd, poi scrivi:
sudo service lightdm stop
invio. poi:
sudo X -configure
invio, continua con:
sudo mv xorg.conf.new /etc/X11/xorg.conf
invio, ora terminando:
sudo service lightdm start
ti ritroverai il tuo xorg.conf in etc/X11
Cita messaggio
Grazie da:
#5
Non so per quale ragione ctrl-alt-f1 o f qualsiasi cosa non mi funzionano più! Prima ero riuscito a farlo e mi ero accorto che un file xorg.conf conteneva delle stringhe.
Le voci però non erano specificate, avevano designazioni di tipo generico. Io ho modificato come nella guida per avere il mio schermo settato, ma non è servito a nulla. Ora mi chiedo, è per il fatto che le voci fossero nulle che non ha funzionato?
E perché xrandr continua a fallire?

E, ulteriore problema, perché non funziona più ctrl-alt-f1?

EDIT: forse ctrl-alt-f1 non funzionano per colpa del nuovo settaggio grafico. Ripristino il vecchio file .conf e vedo che succede. Poi riprovo la procedura che mi hai suggerito e torno.
Cita messaggio
Grazie da:
#6
mi spiace ma non ti posso aiutare. io ti ho solo spiegato come creare il file xorg.conf
se credi che quanto hai fatto prima ti crea problemi, cancella da amministratore il file
etc/X11/conf.org
Cita messaggio
Grazie da:
#7
Grazie lo stesso, intanto aggiorno per chi potesse aiutarmi.


La cosa di ctrl-alt-f1 dovrei averla risolta. Tornando ad X -configure, quando lo faccio l'output è questo:

   


Forse è per questo che il file xorg.conf che mi ritrovo è una roba senza alcuna specificazione e non funziona niente.
Cita messaggio
Grazie da:
#8
se stai usando bumblebee vuol dire che hai due schede video, una del processore e un'altra separata ?
Cita messaggio
Grazie da:
#9
(29-01-2015,16:48 )supertuxkart Ha scritto: se stai usando bumblebee vuol dire che hai due schede video, una del processore e un'altra separata ?

A dire il vero l'ho usato senza sapere bene come funzionasse. Un altro utente mi ha detto che era meglio usare la scheda integrata nel processore, e che per farlo andava bene bumblebee. Io ho seguito la procedura d'installazione di bumblebee e non mi dava più schermata nera nemmeno coi driver proprietari installati (anche se, non so perché, all'ennesima installazione di driver proprietari, i 340.65, mi ha ridato lo stesso problema e ho dovuto rifare tutto. Ora sta funzionando con i driver nouveau per evitare problemi inutili).
Cita messaggio
Grazie da:
#10
Allora non puoi fare il purge remove dei driver che ti danno fastidio e rimettere i vecchi driver ?

Se sono proprietari devono avere una routine di installazione e di disinstallazione in genere e se non levi tutto danno errore.

Ma soprattutto i problemi in genere derivano dal fatto che bisogna disinstallarli tassativamente prima aggiornare il kernel.

prova a leggere questo topic se ti risultasse utile a chiarire quello che devi fare :

http://www.linuxmind-italia.org/index.php?topic=20419.0
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)