Forum Informatica 2 Majorana
[RISOLTO] Il wifi non mi funziona - Versione stampabile

+- Forum Informatica 2 Majorana (http://www.istitutomajorana.it/forum2)
+-- Forum: Software per Ubuntu, Windows, ecc..., Argomenti Vari (http://www.istitutomajorana.it/forum2/Forum-Software-per-Ubuntu-Windows-ecc-Argomenti-Vari)
+--- Forum: Hardware e Componenti PC (http://www.istitutomajorana.it/forum2/Forum-Hardware-e-Componenti-PC)
+--- Discussione: [RISOLTO] Il wifi non mi funziona (/Thread-RISOLTO-Il-wifi-non-mi-funziona)



[RISOLTO] Il wifi non mi funziona - ferguson - 04-12-2015

Saluti a tutti.
Mi sembra che questo problema ve l'ho già posto in passato ma non mi sono trovato niente nelle mie cartelle.
Ho un vecchio computer HP Compaq 6720s con su Ubuntu 12.04 Remix (del Prof. Cantaro) e Windows XP.
Ho voluto reinstallare Ubuntu perché quello vecchio non funzionava più bene ma adesso il problema è che il wifi non funziona e mi serve.
Quando vado sulla scheda "Rete"  delle Impostazioni di sistema mi dice "Firmware Mancante".
Vi posto questo per maggior precisione:

La scheda di rete è una Broadcom BCM4312 802.11b/g LP-PHY

Aiutino?
Grazie mille e cordiali saluti.


RE: Il wifi non mi funziona - Utente01 - 04-12-2015

dovrebbe bastare installare i driver dai repo ufficiali, però , ora che rilascio stai usando  12.04 o hai installato 14.04? perchè su 14.04 dovrebbero essere pacchetti diversi, posta l'output di questo

Codice:
lsb_release -ds && echo $DESKTOP_SESSION && uname -m



RE: Il wifi non mi funziona - ferguson - 04-12-2015

Stai tranquillo, come ho detto ho appena reinstallato Ubuntu 12.04.1 LTS 32 bit


RE: Il wifi non mi funziona - Utente01 - 04-12-2015

ok, allora posta

Codice:
apt-cache policy firmware-b43-lpphy-installer



RE: Il wifi non mi funziona - ferguson - 04-12-2015

Installato: (nessuno)
Candidato: 1:015-9
Tabella versione:
1:015-9 0
500 http://it.archive.ubuntu.com/ubuntu/ precise/multiverse i386 Packages


RE: Il wifi non mi funziona - Utente01 - 04-12-2015

ok, allora prova così, connesso da cavo, dai prima

Codice:
sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
in caso hai installato driver sta, se non cè niente installato te lo dice e poi installa questi

Codice:
sudo apt-get install b43-fwcutter firmware-b43-lpphy-installer
e riprova il wifi, in caso prova anche un riavvio


RE: Il wifi non mi funziona - ferguson - 04-12-2015

Geniale!!!
Adesso appena ho tempo mi stampo il thread e me lo metto nella cartella per il futuro,
Grazie mille e salutoni


RE: [Risolto] Il wifi non mi funziona - Utente01 - 04-12-2015

Ottimo, da ubuntu 14.04 il pacchetto in questione, questo
Codice:
firmware-b43-lpphy-installer
non cè più, le funzioni sono state inserite in firmware-b43-installer

quindi in caso di installazione di 14.04 o successive, il comando è
Codice:
sudo apt-get install b43-fwcutter firmware-b43-installer

Ciao